Could not find a version that satisfies the requirement tensorflow~=1.15.0

I solved the issue by switching to Docker builds.

#1 Added heroku.yml to the root of my project:

build:
  docker:
    web: Dockerfile
run:
  web: python app.py

#2 pip upgrade happens in the Dockerfile:

FROM python:3.7-slim
...
RUN pip install --upgrade pip
RUN pip install --no-cache-dir -r requirements.txt
...

#3 Don’t forget to change the type of your Heroku app:

heroku stack:set container --app YOUR_APP_NAME

This way I was able to control both the Python and the pip version. Prior to moving to the Docker deployments I tried upgrading Python to the latest stack in Heroku (through runtime.txt), but to no avail: pip won’t get upgraded beyond 9.0.x.

2 Likes

Below step will help pip3 install tensorflow==1.5 pip3 install rasa-x --extra-index-url https://pypi.rasa.com/simple --ignore-installed tensorflow

1 Like

Looks like the problem is with Python 3.8. Use Python 3.7 instead. Steps I took to solve this.

  1. Created a python 3.7 environment with conda
  2. Installed rasa using pip install rasa within the environment.

Worked for me.

1 Like
  1. Uninstall python-pip
$ sudo apt remove pyhton-pip
  1. Install Python3-pip
$ sudo apt install python3-pip
  1. Upgrade pip using python3 -m
$ python3 -m pip install --user --upgrade pip
  1. Install rasa using python3-m
$ python3 -m pip install --user rasa 

This is cos the version of TF (1.15) that the rasa installer requires is pretty old and isn’t compatible with python 3.8. The solution would be to downgrade python to 3.6 (maybe 3.7) and try again.

TF on it’s own works fine with python 3.8:

pip install https://storage.googleapis.com/tensorflow/mac/cpu/tensorflow-1.8.0-py3-none-any.whl

this is what I did on a mac: I already had python3.6 installed with brew

brew link --overwrite python
python3.7 --version
virtualenv -p python3.7 venv
source venv/bin/activate

# then this will work
pip install rasa

is --user equally relevant for a virtualenv what versions are you expecting to arrive at?

I thought this problem is the version of TF being used is related to a specific python version? maybe worth posting your exact env that you were able to install with?

I can confirm your solution did NOT work with a python 3.8 virtual env

you have a typo

I faced the same issue. Solved by using python:3.7.4 and pip:20.0.2

@JulianGerhard @pi4n0m4n PLease help i have face same problem from last 5 days .

Hi @rahulkoundal,

could you please provide some more information about:

  • OS?
  • Python Version?
  • Virtual Environment?
  • pip Version?

Did you try some of the above hints / solutions?

Kind regards
Julian

pip 20.0.2 python 3.6.3 window 10 please solve this issue @JulianGerhard yes i try all the above hint but its not working me for know

Hi @rahulkoundal,

ok - which Rasa version would you like to install?

Kind regards
Julian

i simply run pip install rasa @JulianGerhard

@JulianGerhard is there any other way of installing it please give me becuase now it impact my work . Its working in my linux but now i am shifting linux to window so last 5 days i face this issue

Hi @rahulkoundal,

ok - could you please source your virtual environment and use:

pip install https://storage.googleapis.com/tensorflow/windows/cpu/tensorflow_cpu-2.1.0-cp36-cp36m-win_amd64.whl

If you are not familiar with virtual environments in Windows, please use this tutorial in advance.

Please post your feedback here afterwards.

Kind regards
Julian

this error @JulianGerhard

no i have knowledge of virtual environments in Windows but don’t have knowledgw of rasa on window

Hi @rahulkoundal,

how about:

pip3 install tensorflow --extra-index-url=https://www.piwheels.org/simple

Kind regards
Julian

@JulianGerhard

@rahulkoundal

Sorry I meant:

pip3 install tensorflow --extra-index-url https://www.piwheels.org/simple