"Could not find a version that satisfies the requirement aiohttp~=3.5"

Apologies if this has been answered already but I didn’t find an answer searching here as to why I get “ERROR: Could not find a version that satisfies the requirement aiohttp~=3.5” when trying to run (the Getting Started on Mojave) “pip install rasa-x --extra-index-url https://pypi.rasa.com/simple

full output: DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at Release process — pip 19.3.dev0 documentation Looking in indexes: https://pypi.org/simple, https://pypi.rasa.com/simple Collecting rasa-x Downloading https://pypi.rasa.com/api/package/rasa-x/rasa-x-0.20.1.tar.gz (1.4MB) |████████████████████████████████| 1.4MB 2.6MB/s Installing build dependencies … done Getting requirements to build wheel … done Preparing wheel metadata … done Collecting aiohttp~=3.5 (from rasa-x) ERROR: Could not find a version that satisfies the requirement aiohttp~=3.5 (from rasa-x) (from versions: 0.1, 0.2, 0.3, 0.4, 0.4.1, 0.4.2, 0.4.3, 0.4.4, 0.5.0, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.10.0, 0.10.1, 0.10.2, 0.11.0, 0.12.0, 0.13.0, 0.13.1, 0.14.0, 0.14.1, 0.14.2, 0.14.3, 0.14.4, 0.15.0, 0.15.1, 0.15.2, 0.15.3, 0.16.0, 0.16.1, 0.16.2, 0.16.3, 0.16.4, 0.16.5, 0.16.6, 0.17.0, 0.17.1, 0.17.2, 0.17.3, 0.17.4, 0.18.0, 0.18.1, 0.18.2, 0.18.3, 0.18.4, 0.19.0, 0.20.0, 0.20.1, 0.20.2, 0.21.0, 0.21.1, 0.21.2, 0.21.4, 0.21.5, 0.21.6, 0.22.0a0, 0.22.0b0, 0.22.0b1, 0.22.0b2, 0.22.0b3, 0.22.0b4, 0.22.0b5, 0.22.0b6, 0.22.0, 0.22.1, 0.22.2, 0.22.3, 0.22.4, 0.22.5, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.5, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.2.0, 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 2.0.0rc1, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6.post1, 2.0.7, 2.1.0, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.2.4, 2.2.5, 2.3.0a4, 2.3.0, 2.3.1, 2.3.2b2) ERROR: No matching distribution found for aiohttp~=3.5 (from rasa-x)

You need to use python 3.5+

Thanks: python 3.7.x is also installed, but for those on Mojave who run into this problem (since MacOS uses python 2.7 at the OS level), you may need to overwrite the version that PIP will use by prefacing the command: “python3 -m pip install rasa-x --extra-index-url https://pypi.rasa.com/simple

I got the same issue. I am on python 3.6 and pip version 20.0.2. I also tried to separately install aiohttp

pip3 install aiohttp works fine. I think the dependency is false, does aiohttp 3.5 even exist?. I tried to install rasa for the last 2 h now trying different combinations of rasa versions and python versions, but none worked. Before aiohttp it was failing at tensorflow. I suggest to clone the code from github.

What command do you use to install rasa please send us

I tried

pip install rasa pip3 install rasa I also tried to install previous versions , I believe I tried 1.5. and also tried different python versions as well.

But I figured it out now.

  • Use python version 3.6.8
  • use MS build tools version 14.0 (2015) - I had the 2017 version and that did not work
  • check in your environment variables that 3.6.8 path is above other python versions you might have
  • upgrade pip > python -m pip install --upgrade pip
  • also update setuptools > pip install --upgrade setuptools
  • last but not least try >pip rasa install

If you are building from source:

  1. $ curl -sSL https://raw.githubusercontent.com/python-poetry/poetry/master/get-poetry.py | python
  2. $ git clone https://github.com/RasaHQ/rasa.git
  3. $ cd rasa
  4. $ python -m pip install --upgrade pip
  5. $ pip install --upgrade setuptools
  6. $ poetry env use python
  7. $ poetry install
  8. make a directory for your first rasa project, and navigate to it in your cmd window
  9. $ rasa init
  10. follow the instructions Step 4 and 5 are essential python3.6 comes with ancient pip and setuptools that don’t recognize wheels. And you have to upgrade before you build you poetry environment. If you have forgotten to do this go to C:\Users…\AppData\Local\pypoetry\Cache delete the “virtualenvs” directory and redo steps 4-7.

Hope that helps :slight_smile: