Connection error - socket io

Hi ,

I am trying to connect to my rasa instance via python socket io client to perform a test. RASA is up & running and enabled for /socket.io

Below is my client code:

import socketio

sio = socketio.Client()
sio.connect("http://localhost:5005/socket.io", transports= 'websocket')

When I run this, I can see User OLjL2P8m2rj3TRm4AAAA connected to socketIO endpoint. followed by the below Traceback on the rasa server side.

Traceback (most recent call last):
  File "d:\venv\rasax_0_31_5\lib\site-packages\engineio\asyncio_server.py", line 447, in _trigger_event
    ret = await self.handlers[event](*args)
  File "d:\venv\rasax_0_31_5\lib\site-packages\socketio\asyncio_server.py", line 516, in _handle_eio_connect
    return await self._handle_connect(sid, '/')
  File "d:\venv\rasax_0_31_5\lib\site-packages\socketio\asyncio_server.py", line 435, in _handle_connect
    namespace=namespace))
  File "d:\venv\rasax_0_31_5\lib\site-packages\socketio\asyncio_server.py", line 405, in _send_packet
    await self.eio.send(sid, encoded_packet, binary=False)
TypeError: send() got an unexpected keyword argument 'binary'

On the client side, I see a Connection error as below.

Any direction to resolve this. Thanks in advance.

@siriusraja update the versions of

python-engineio 
python-socketio 

May be it will solve your issue or update the rasa version.

1 Like

Hi @nik202

Thank you for the suggestion. Upgrading python-engineio & python-socketio solved the issue.

1 Like

@siriusraja please close this thread with the solution for others thanks.