Can't upload to model to Rasa X - Docker Compose

Hello everyone,

I had just installed Rasa X on Windows according to the official Docker Compose installation and I went with the manual installation. The Compose file is all good, and I can reach the UI, everything seems to be working fine. The problem is that when I try to upload a model with curl I just get a http 500:

Looked for errors everywhere, and after a while also found this in the nginx logs:

It shows nothing, just a reminder that the upload failed. I couldn’t find anything elsewhere, so I’m a little lost. Also getting the same error if uploading by the upload button in the UI, but again, no details. I also get this error from the production and worker container whenever trying to upload a model:

My Rasa X details:

Checked the compatibility matrix, all is good, and I’m using the 2.8.26 version of the official Rasa for the production and worker containers. I’ve researched this topic quite a bit and found that maybe the configuration of a given model is wrong, but the model’s version matches the used, 2.8.26 version.

Can you please help me or point somewhere I can look for any logs or details on the error?

Thanks in advance

@chef There is no installation process for using Rasa X 1.1.0 using docker-compose. Ref: Installation Guide

@nik202 Hey man

Thanks for the quick response. I changed the Rasa X and Rasa X demo images’ version to 1.0.0, but still nothing. Even had the login problem, where the admin or me user wasn’t created. Again, the upload button doesn’t work, nor does the api, getting the same error 500. Also still getting the fetching error from the worker and production containers though. Any ideas?

using docker-compose for Rasa X 1.x?

Yes, used this as a guide for the manual installation: Docker Compose Installation


it’s not a mentioned installation on the official Rasa Doc : Installation Guide

The mentioned link, I already mentioned to the team many times. I hope they will make the necessary changes.

@nik202 Oh okay, thank you. So is there any way to install Rasa X and train models with the UI in Docker or there is none for now?

@chef you can try docker-compose with the following configuration, hope this will help Rasa 2.8.11 or Rasa 2.8.15 with Rasa X 0.42.5 Ref: Installation Guide

Tips: Do read this above-mentioned documentation in detail for custom action image and connecting Git.

Good Luck!

Thank you for all your help man, but I’m still stuck. Used you suggestion, can’t even get past the login screen. The default generated login password doesn’t work. Tried modifying the rasa_x_user table but nothing, I can’t get in, so can’t really test anything. Any ideas on how to log in or enable auth by username/password?

@chef I highly recommend to tag me.

@chef can you share with me the screenshot or errors?

@nik202 This is the only error I get, looked everywhere:

Just the basic wrong credentials error. Nothing in the nginx container, not even a http error. I am starting to get lost in this whole project :sweat_smile:

@chef do check docker ps that rasa x is running or not or create the password again.