Cannot upgrade deployment in kubernates

I’ve deployed rasa x on kubernates using aws eks. Now I want to enable ssl so I’ve read The Complete Guide To Deploying Your Rasa Assistant | The Rasa Blog | Rasa

When I ran the command

helm upgrade \
    --values values.yml \
    --namespace <namespace>\
    --reuse-values \
    <release> rasa-x/rasa-x

I get the error

Error: UPGRADE FAILED: execution error at (rasa-x/charts/rabbitmq/templates/NOTES.txt:170:4): 
PASSWORDS ERROR: You must provide your current passwords when upgrading the release.
                 Note that even after reinstallation, old credentials may be needed as they may be kept in persistent volume claims.
                 Further information can be obtained at https://docs.bitnami.com/general/how-to/troubleshoot-helm-chart-issues/#credential-errors-while-upgrading-chart-releases

    'auth.erlangCookie' must not be empty, please add '--set auth.erlangCookie=$RABBITMQ_ERLANG_COOKIE' to the command. To get the current value:

        export RABBITMQ_ERLANG_COOKIE=$(kubectl get secret --namespace "<namespace>" rasa-x-1642681777-rabbit -o jsonpath="{.data.rabbitmq-erlang-cookie}" | base64 --decode)

Whilst I did provide a rabbit password for deployment to eks, in my new values.yml file, I did not provide it. The new values.yml is as follows:

ingress:
  annotations:
    ingress.annotations.certmanager.k8s.io/cluster-issuer: letsencrypt-prod
    kubernetes.io/ingress.class: traefik
  hosts:
    - host: xxxx.us-east-1.elb.amazonaws.com
      paths:
      - /
  tls:
   - secretName: rasa-tls
     hosts:
       - xxxx.us-east-1.elb.amazonaws.com

I’ve been stuck here and couldn’t figure out what’s going on. Would appreciate any help

Hello @Smokes12 did you solve this issue? I’m stuck at helm upgrade too. Again and again I have to reinstall the helm chart and bring up Rasa X again because of this. If only helm upgrade could work

1 Like

I’m also getting this issue. It seems to also be an issue here: Rasa server cannot connect to Rasa X

Any help from Rasa developers much appreciated

Ah I found the solution is simply to ensure when you first create the server to specify the auth.password and auth.erlangCookie. You also need to ensure rabbitmq is enabled; it is needed for Rasa-X to display output correctly and to avoid the error from this thread.

rabbitmq:
  enabled: true
  install: true
  auth:
    password: <specify>
    erlangCookie: <specify>

if you still get the error after this, check that doing what it says actually retrieves a value

i.e. check that export RABBITMQ_ERLANG_COOKIE=$(kubectl get secret --namespace "<namespace>" rasa-x-1642681777-rabbit -o jsonpath="{.data.rabbitmq-erlang-cookie}" | base64 --decode) Is actually producing a valid string, as if it is not, it suggests that maybe your rabbit deployment has failed in some way, and that’s your issue.

As the warning says, you can actually manually specify this to the upgrade command by then adding --set auth.erlangCookie=$RABBITMQ_ERLANG_COOKIE - but it won’t work if rabbit is not setup correctly on the initial deployment start.