Cannot terminate rasa action server and rasa run using "Ctrl + c" or "Ctrl + Pause" in command prompt

whenever I run rasa run actions or rasa run , I cannot terminate it in terminal using keys. I tried to reset my window but it’s still doesn’t work

I have the same problem in rasa run actions as well as rasa run --enable-api …

I have to restart the shell for every small update.

I face the same issue. Wondering if there is a magical combination of keys that terminates the action server. Also, is there any way to make the action server pick up the latest changes in the actions.py file without aborting the action server?

CTRL + Pause is working for me.

Hi, I been having the same problem, I found out that using the function key helps. My keyboard does not have a pause key so I tried ctrl + fn + B, and it worked!! Where fn is the function key.

I have to use CTRL+c two times and it works.

Solution for Windows user and this is working in both cmd and anaconda prompt.

I’m also facing the same issue in my windows and I solve it by using Ctrl + fn + Shift (pause) key.

Thanks

1 Like

Had the same issue. Solved it by a combination of Ctrl + Fn + B.

Unfortunately, none of these solutions works for me. Is there any other way?

1 Like

Same here … None of them worked for me :confused:

I am also facing same issue without --enable-api i don’t have a problem but with them the ctrl+c doesn’t work @rctatman please check as this issue I m facing in rasa 2.2.0 .Till rasa 1.9 version I haven’t faced so

Looks like it might be a bug. Would you mind creating an issue on GitHub? Issues · RasaHQ/rasa · GitHub :pray:

1 Like

Sure, Raised as issue in Cannot terminate rasa action server and rasa run using “Ctrl + c” or “Ctrl + Pause” in command prompt · Issue #7901 · RasaHQ/rasa · GitHub.

1 Like