Cannot specify endpoints while using

I am running my model using the command:

python -m -d models/dialogue -u models\default\model_20190110-113631 --port 5004 --credentials credentials.yml

Which runs and works flawlessly. I can POST messages and get responses. But when I try to specify action endpoints for custom actions using --endpoints endpoints.yml I get the following error in rasa_core/

  File "C:\Users\user\AppData\Local\Continuum\anaconda3\envs\rasaenv\lib\site-packages\rasa_core\", line 752, in from_dict
    return EndpointConfig(**data)
TypeError: type object argument after ** must be a mapping, not NoneType

I’m on the latest version of rasa_core: 0.12.4

EDIT: Solved it. There was was weird indentation in my endpoints.yml. Feel silly now

1 Like

can you share your endpoints file? and your custom action file? There is some argument error you might have made in custom action.

You are running the custom action server right? with this command:

python -m rasa_core_sdk.endpoint --actions

My endpoints.yml had some weird indentation fault. Using tabs fixed it. :sweat_smile:

1 Like

Thanks for posting your solution!!! I was getting this this morning on our production server and couldn’t figure it out. I had swapped the production action server endpoint (un-commented it) and there was NO indent at all. Ugh. Was chasing my tail until I decided to search here :slight_smile: