Cannot install Rasa X - sqlalchemy.exc.OperationalError: (sqlite3.OperationalError) no such column: True

Hi,

I looked at this thread which is reporting the same error but it’s not clear how it was fixed. So I am raising it again here to get some help …

I am running the following versions:

rasa 2.8.1 rasa-sdk 2.8.1 rasa-x 0.42.0

I am using Ubuntu 18.04 and running Python 3.6.9.

I have tried deleting the events and rasa db files (which previously worked for me) via this thread but I’m afraid it still doesn’t work. I had the same error with rasa 2.7.1 and corresponding SDK and rasa-x versions from the compatibility matrix.

Can anybody help?

Thanks!

@pomegran Downgrade to rasa-x==0.39.3

pip install rasa-x==0.39.3 --extra-index-url https://pypi.rasa.com/simple

Somre errors:

ImportError: cannot import name ‘RowProxy’ from ‘sqlalchemy.engine’ try running pip install SQLAlchemy==1.3.22 should fix it.)

And, if you get an error not being able to import yaml then run pip install pyyaml.

Good Luck!

1 Like

That’s fabulous, thank you!

In the interests of completeness, I returned to my original Rasa 2.7.1 and Rasa-sdk 2.7.0. Installed Rasa X 0.39.3 and then needed to run:

pip install SQLAlchemy==1.3.22

All worked!

Are there problems with Rasa X post 0.39 then?

Thanks for your help! Much appreciated.

1 Like

@pomegran Congratulations Mark :handshake: Party :clinking_glasses:. I guess its a backend issue in Rasa, hope they will solve it soon.

:+1: