Cannot find rasa after "installation" on BigSur M1

I followed the installation steps including

brew update brew install python activate virtual environment (also tried without this) pip3 install rasa

When that all finishes, I do

rasa init

and get zsh: command not found: rasa

I’m running

macOS Big Sur 11.1 Python3 3.9.1 pip 20.3.3

One suspicious thing:

pip3 list shows

rasa 0.0.5

I don’t know where it gets the ‘latest’ version from. How do I get the latest version of Rasa instead of 0.0.5?

This also does not work, possibly because the version is too low:

python -m rasa init

as it gives:

Error while finding module specification for ‘rasa.main’ (ImportError: cannot import name ‘ASA’ from partially initialized module ‘rasa’ (most likely due to a circular import) (/…clip…/rasa/venv/lib/python3.9/site-packages/rasa/

Other things I’ve done:

I’ve doubled checked the path, and attempted to put various locations of python on the path, but no help.

I’ve attempted in use brew to install python3-devel but doesn’t find it.

I’ve attempted to build from source but upon running ‘poetry install’ I get “Poetry could not find a pyproject.toml file”

I would have attempted to run a Linux on a virtualized environment, but VirtualBox does not run 64-bit Intel VMs on M1 as far as I understand it.

Python3 states that 3.9.1 is the earliest version of python supported on Big Sur. Anyway my attempts to downgrade python did not work, as I get error “configure: error: Unexpected output of ‘arch’ on OSX”

I am taking same error, and I am still couldn’t find solution.

Rasa works on python 3.6/3.7/3.8 (see here.))

However, Rasa doesn’t seem to work yet on Apple M1. See my post here.

OK, thanks.

I’ve written a small, but unofficial guide, that seems to work.