Bug in sequential utterances which has buttons

Hi, I am trying for the following conversation.

user: I want to know more.
Bot: For more details, click the following button
More details
Alternatively, you could choose one of the following options too.
Something else [Button-1]
Restart [Button-2]

##  chat
* more_details
  - utter_more_details
  - utter_other_options  
- text: "For more details, click the following button."
    - title: "More Details"
      payload: "/intent_moredetails"

- text: "Alternatively, you could choose one of the following options too."
    - title: "Something else"
      payload: "/intent_somethingelse"
    - title: "Restart"
      payload: "/intent_restart

I tried this using these UIs - chatbot-widget, rasa-webchat and chatroom

But, the utterances in the UI are not displaying in order. Instead, both the statements are displaying first. Then all 3 buttons.

@JiteshGaikwad. Could you help me with this? Thank you.

I even tried in rasa-shell, but only the second utterance is being displayed.

I can sort of reproduce this on Rasa 2.0, I see button - both sentences - rest of buttons:

Could you open an issue on github for this?

Hi @mloubser, yeah I check with rasa 2.0 and its working as expected. But, in Rasa 1.10.15 and 1.10.17, the first statement and associated button is not being displayed in the shell when running with rasa shell --debug

Right, you can open github issue to report this here: https://github.com/RasaHQ/rasa/issues/new?assignees=&labels=area%3Arasa-oss+%3Aferris_wheel%3A%2Ctype%3Abug+%3Abug%3A&template=bug_report.md&title=