Bot shows not secure not supporting https

i am running the bot in test server but it is not working in HTTPS can any one please help me

image

i have click on load unsafe scripts then bot is showing

I’m not sure from you description above, if your setup matches mine, but here’s what I’ve done.

I’m running my bot processes in docker containers and the core is using socket io transport on port 5005 without HTTP. This port is not accessible to the internet as it’s sitting behind a firewall. I then run nginx, in another docker container, as a reverse proxy server. Nginx sits on port 8443 with HTTPS set up on the domain. The nginx proxy simply forwards the incoming HTTPS connections to the upstream HTTP server on port 5005. Only the nginx HTTPS port is accessible on the internet.

I have not used docker to run in the sever

just i have kept my host name,

like socker url: http://xyx:5005

You don’t need to use docker - I just find it simpler to set up. So you either need to run the socket.io layer with HTTPS (I couldn’t work out how to do that) or put an HTTPS proxy (like nginx) in front of it and have your client connect to that.

This stopped browsers from blocking connections to my bot.

credential.yml

socketio: user_message_evt: user_uttered bot_message_evt: bot_uttered session_persistence: true

rasa: url: “https://localhost:5002/api

i have changed to https but i am getting http only

can you please guide me

My suggestion is that you try using an nginx proxy. The proxy will need to be configured with a valid certificate in order to use ssl and thus accept https requests. I use certbot to get free certificates from LetsEncrypt. You then just setup nginx to listen on some port (I’m using 8443) for https connections from the chatroom widget running on your https-enabled host webpage. The nginx proxy, listening for https connections will forward them to your bot that’s listening on port 5005 using http, handling all the needed https <-> http conversions. To your browser, everything will appear to be served over https and it will then be a happy browser and allow the connection to happen without complaining.

There are plenty of online resources available about running nginx as a proxy.

There are probably other ways to solve this, but I’ve no experience of them. What I described above solves the problem you posted about in the first post, for the way I’m running things. I don’t know if it will for you.