AttributeError: Can't get attribute 'FeatureArray' on <module 'rasa.utils.tensorflow.model_data'

Hello, I have updated my Rasa from version 1.10.0 to the latest version 2.2.2. I have changed every file according to the new structure. Also, I have updated the RASA-X to the latest version 0.34.0.

Everything runs smooth. When I upload a modal and activate it, my rasa-production docker is giving me an error and my modal is not getting used ( If I understand logs properly ).

Error: ERROR rasa.core.agent - Failed to update model. The previous model will stay loaded instead.

AttributeError: Can’t get attribute ‘FeatureArray’ on <module ‘rasa.utils.tensorflow.model_data’ from ‘/opt/venv/lib/python3.7/site-packages/rasa/utils/tensorflow/model_data.py’>

Any solution for this error? Or what I am missing while updating to the latest version from Version 1.10.0 to 2.2.2 ?

1 Like

Still stuck on this… Can anyone help me out?

I have the same issue

2021-01-09 12:58:22 ERROR rasa.core.agent - Failed to update model. The previous model will stay loaded instead. rasa-worker_1 | Traceback (most recent call last): rasa-worker_1 | File "/opt/venv/lib/python3.7/site-packages/rasa/core/agent.py", line 159, in _update_model_from_server rasa-worker_1 | _load_and_set_updated_model(agent, model_directory, new_fingerprint) rasa-worker_1 | File "/opt/venv/lib/python3.7/site-packages/rasa/core/agent.py", line 132, in _load_and_set_updated_model rasa-worker_1 | interpreter = _load_interpreter(agent, nlu_path) rasa-worker_1 | File "/opt/venv/lib/python3.7/site-packages/rasa/core/agent.py", line 91, in _load_interpreter rasa-worker_1 | return rasa.core.interpreter.create_interpreter(nlu_path) rasa-worker_1 | File "/opt/venv/lib/python3.7/site-packages/rasa/core/interpreter.py", line 33, in create_interpreter rasa-worker_1 | return RasaNLUInterpreter(model_directory=obj) rasa-worker_1 | File "/opt/venv/lib/python3.7/site-packages/rasa/core/interpreter.py", line 127, in __init__ rasa-worker_1 | self._load_interpreter() rasa-worker_1 | File "/opt/venv/lib/python3.7/site-packages/rasa/core/interpreter.py", line 164, in _load_interpreter rasa-worker_1 | self.interpreter = Interpreter.load(self.model_directory) rasa-worker_1 | File "/opt/venv/lib/python3.7/site-packages/rasa/nlu/model.py", line 318, in load rasa-worker_1 | return Interpreter.create(model_metadata, component_builder, skip_validation) rasa-worker_1 | File "/opt/venv/lib/python3.7/site-packages/rasa/nlu/model.py", line 345, in create rasa-worker_1 | component_meta, model_metadata.model_dir, model_metadata, **context rasa-worker_1 | File "/opt/venv/lib/python3.7/site-packages/rasa/nlu/components.py", line 814, in load_component rasa-worker_1 | component_meta, model_dir, model_metadata, cached_component, **context rasa-worker_1 | File "/opt/venv/lib/python3.7/site-packages/rasa/nlu/registry.py", line 178, in load_component_by_meta rasa-worker_1 | component_meta, model_dir, metadata, cached_component, **kwargs rasa-worker_1 | File "/opt/venv/lib/python3.7/site-packages/rasa/nlu/classifiers/diet_classifier.py", line 977, in load rasa-worker_1 | ) = cls._load_from_files(meta, model_dir) rasa-worker_1 | File "/opt/venv/lib/python3.7/site-packages/rasa/nlu/classifiers/diet_classifier.py", line 998, in _load_from_files rasa-worker_1 | data_example = io_utils.pickle_load(model_dir / f"{file_name}.data_example.pkl") rasa-worker_1 | File "/opt/venv/lib/python3.7/site-packages/rasa/utils/io.py", line 80, in pickle_load rasa-worker_1 | return pickle.load(f) rasa-worker_1 | AttributeError: Can't get attribute 'FeatureArray' on <module 'rasa.utils.tensorflow.model_data' from '/opt/venv/lib/python3.7/si

Just as an FYI it trains and runs from the command line on a fresh install just fine

Yes on the command line it runs perfectly. Do you manage to run it on RASA-X?

No Rasa-x does nothing but the model seems to be missing the intents and stories despite training perfectly without errors or warnings at the command line.

The intent carddetails was found in the domain but is missing in the training data.

Okay,. I haven’t found that error. Will look into this. But yes RASA-X is not working. I am amazed why there is no response from Rasa Official.

Hi,

we had this exact same issue with some people in my team. We resolved it by upgrading everyone’s Python version to 3.8. Good luck!

I’m using the official Docker files so tied to whatever version of Python the script says sadly but thanks for the tip.

Just tried with a clean install of 0.35 and still doesn’t work - version 2 seems to be VERY buggy.

Will give it a try

Same here