Aiohttp error on Mac

Trying to install RASA. Getting aiohttp error. Tried installing aiohttp from their website separately and referring docs, but in vain.

The problem is: My python -V shows 2.7. And Python3 shows 3.6, but while installing RASA is not pointing aiohttp in the direction of python3. How can point to RASA installation to use python3 and not python. Tried first updating python, installing homebrew and updating python, updated pip version too. Nothing worked. Thanks.

Hi @akshaybagde! Are you using a virtual environment?

Thank you for your reply. I tried doing it both ways, with and without virtual environment, but no luck. I used venv as you mentioned in your reply. Thanks

@akshaybagde Even if you activate your environment, python -V shows 2.7? Are you installing using this command: pip install rasa-x --extra-index-url

Thanks for getting back @tyd. My python -V shows 2.7 as it was the default version which was installed by apple. Here is a post which shows the problem that I am facing.

The problem is, I cannot tell RASA to use python 3. And yes, I am running the same command as you mentioned. Thanks

@akshaybagde When you activate the virtual environment, python -V should show the version of python you created the environment using. Does it not?

I also have default version of python installed by apple (2.7) on my macbook and then installed python3 using homebrew. As you can see, python -V outside of the virtual environment shows 2.7, but after I activate my environment, python -V show 3.7

To @akshaybagde or anyone else getting this issue, if you installed python3 on a Mac, you’ll want to make sure you are using pip3 instead of pip:

pip3 install rasa-x --extra-index-url

I would recommend using a virtual environment as well to avoid dependency conflicts.

1 Like