About the [Deprecated] Rasa X Community Edition category

We have decided that we will no longer maintain or support Rasa X Community Edition. Learn more here: Changes to the Rasa X Community Edition (Free Version)

1 Like

Thanks!! :slight_smile: really exicted to try out the Rasa X

Just as an fyi, the install link on our docs is wrong (being fixed as we speak). Please use this one:

pip install rasa-x --extra-index-url https://pypi.rasa.com/simple

hi @akelad I had tried the above commnd but still it show the error

hey @akelad I had fixed the issue now it working fine, just uninstall the rasa-x and installed it again, everything works fine :slight_smile:


Running Rasa X inside of the moodbot example gives me this stacktrace.

Process SpawnProcess-1:
Traceback (most recent call last):
  File "/usr/local/Cellar/python/3.6.5_1/Frameworks/Python.framework/Versions/3.6/lib/python3.6/multiprocessing/process.py", line 258, in _bootstrap
  File "/usr/local/Cellar/python/3.6.5_1/Frameworks/Python.framework/Versions/3.6/lib/python3.6/multiprocessing/process.py", line 93, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/local/lib/python3.6/site-packages/rasa/cli/x.py", line 74, in _rasa_service
  File "/usr/local/lib/python3.6/site-packages/rasa/core/run.py", line 135, in serve_application
    input_channels, cors, auth_token, enable_api, jwt_secret, jwt_method, port=port
  File "/usr/local/lib/python3.6/site-packages/rasa/core/run.py", line 85, in configure_app
    rasa.core.channels.channel.register(input_channels, app, route=route)
  File "/usr/local/lib/python3.6/site-packages/rasa/core/channels/channel.py", line 75, in register
    app.blueprint(channel.blueprint(handler), url_prefix=p)
  File "/usr/local/lib/python3.6/site-packages/rasa/core/channels/telegram.py", line 243, in blueprint
  File "/usr/local/lib/python3.6/site-packages/telegram/bot.py", line 65, in decorator
    result = func(self, *args, **kwargs)
  File "/usr/local/lib/python3.6/site-packages/telegram/bot.py", line 2070, in set_webhook
    result = self._request.post(url_, data, timeout=timeout)
  File "/usr/local/lib/python3.6/site-packages/telegram/utils/request.py", line 309, in post
    headers={'Content-Type': 'application/json'})
  File "/usr/local/lib/python3.6/site-packages/telegram/utils/request.py", line 223, in _request_wrapper
    raise BadRequest(message)
telegram.error.BadRequest: Bad webhook: failed to resolve host: name or service not known

Then it opens the browser with the url http://localhost:5002/login?username=me&password=j1cc09Xh6dOZ

However, the browser is giving me a 404 not found for the login route.

I need some help server side, and/or a troubleshooting page. I installed no problem, my ip address brings up my Rasa X instance, but can’t change the password, I think it is wrong as well (the command is create) and I cannot click on sign in or anything else. It says I need to fill out the entire form? Any ideas?

@adrianhumphrey111 hmm it seems to be trying to run a telegram webhook, can you make sure that section is commented out in the credentials.yml if you’re not using it?

1 Like

You are right, I commented it out and I am still getting a 404 error in the browser visiting the url that is spits out.

The server is running at http://localhost:5002/login?username=me&password=ekpKs7OPGNa4

Can you show me your logs?

I’m not sure if this is the right place to put this, but I think it can be seen as a question / feedback.

When I want to go to interactive learning, I can only copy a story from the beginning. So from the restart until a certain point inside that story. Is it, or can it be made possible to copy only a part of a story to interactive learning?

I’ll show what I mean with an example.

----- start of a story -----

  1. U: Hey
  2. Bot: Hello
  3. U: Bye
  4. Bot: See you!
  5. U: Hello
  6. Bot: Hello
  7. U: How are you?
  8. Bot: I’m fine, thank you
  9. U: What is your name?
  10. B: I don’t have a name yet

— start of a new story —

I can now only copy the story starting at 1, however I would like the story to start at sentence 5 and do the interactive learning from there.

When I run the script migration with oracle dialect at new_endpoints:

  type: sql
  dialect: "oracle"
  port: 1521
  username: rasa-x
  password: admin
  db: dese

I take this:

sqlalchemy.exc.OperationalError: (psycopg2.OperationalError) could not translate host name "db" to address: Unknown host

The events and conversations SID(database) is the same, differencieted by username. What is the correct configuration, I need two bases?

hey @Juste, i’m just getting started with rasa and i want to know if integrating rasa x with fb and sites is free?

Hi all @akelad

Can we populate the questions or the different variations of questions when the user begins to type in his query from the intents?If it is possible how can it be done?

Thanks in advance

Hi all. I am facing one problem when handling multiple entities. I posted a question but i didn’t get any response. Please help me to find the solution to this problem You can find my post here How to map multiple items and their quantities rasa x

Hi, i want to install rasa-x on my own server but i can’t it takes to many times. I want to know why? the criterian of the server are: CPU 5, Ram 8 and disk 300.