When trying to run Rasa X

I get this error when I run this “Rasa X”

strong textTraceback (most recent call last): File “C:\Users\HHIHQ MEDIA\anaconda3\envs\assistant\lib\site-packages\rasa\cli\x.py”, line 502, in run_locally domain_path=domain_path File “C:\Users\HHIHQ MEDIA\anaconda3\envs\assistant\lib\site-packages\rasax\community\local.py”, line 226, in main rasax.community.jwt.initialise_jwt_keys() File “C:\Users\HHIHQ MEDIA\anaconda3\envs\assistant\lib\site-packages\rasax\community\jwt.py”, line 74, in initialise_jwt_keys private_key, public_key = cryptography.generate_rsa_key_pair() File “C:\Users\HHIHQ MEDIA\anaconda3\envs\assistant\lib\site-packages\rasax\community\cryptography.py”, line 28, in generate_rsa_key_pair backend=default_backend(), File “C:\Users\HHIHQ MEDIA\anaconda3\envs\assistant\lib\site-packages\cryptography\hazmat\backends_init_.py”, line 14, in default_backend from cryptography.hazmat.backends.openssl.backend import backend File “C:\Users\HHIHQ MEDIA\anaconda3\envs\assistant\lib\site-packages\cryptography\hazmat\backends\openssl_init_.py”, line 6, in from cryptography.hazmat.backends.openssl.backend import backend File “C:\Users\HHIHQ MEDIA\anaconda3\envs\assistant\lib\site-packages\cryptography\hazmat\backends\openssl\backend.py”, line 113, in from cryptography.hazmat.bindings.openssl import binding File “C:\Users\HHIHQ MEDIA\anaconda3\envs\assistant\lib\site-packages\cryptography\hazmat\bindings\openssl\binding.py”, line 14, in from cryptography.hazmat.bindings._openssl import ffi, lib ImportError: DLL load failed: The specified procedure could not be found.

Hi @CliveMakunga and welcome to the forum!

can you share the rasa --version ?

rasa v

@CliveMakunga Ok! Now please share the error screenshot for me and complete error starting from rasa x or whatever command you had run?

Please always mention the right tag i.e @ and name in my case (nik202)

@CliveMakunga please confirm me that are you able to run rasa shell --debug and able to talk to the bot. If not please check now and if there is any error, please share the screenshot.

Yes I am able to talk to the bot.

@CliveMakunga Strange. At the time of installing rasa x or rasa open source did you get some warning or error? If occur hope you managed them?

The only error I got was that of visual c++ but I fixed eventually by install the visual c++

@CliveMakunga Clive what is your project folder name, in which you installed the rasa init ?

HHIHQ MEDIA is your user name right?

Where is project folder?

Are you sure you are in right project folder?

Solution: go the project folder and then run rasa x please.

I cd into the project folder and got the same error


I’d recommend and suggest, please start with the fresh approach and create the fresh project folder and follow the below mention steps. Its fine take your time and do share me the errors as you encountered.

For Installation please follow these steps:

Please follow these steps for the installation of ROS and Rasa X :slight_smile:

Note: You can ignore a few steps if you already performed it!

:wink: But I’d recommend starting the fresh installation without seeing any video, please.

Please install Anaconda from Anaconda | Individual Edition , then create the conda environment using the following command

  1. conda create -n rasa3 python=3.8
  2. conda activate rasa 3

PS: If you using Linux, check the environment for the same.

Note: I’d recommend to create a fresh environment if not you can proceed with next steps:

For Rasa Open Source:

`pip install rasa==2.8.1`
`pip install rasa-sdk==2.8.1'

check version rasa --version its install or not

For Installing basic project:

rasa init

then if you need

For Rasa-X Installation

pip install rasa-x==0.39.3 --extra-index-url https://pypi.rasa.com/simple

check rasa version rasa --version its install or not

You will see some error : ImportError: cannot import name ‘RowProxy’ from ‘sqlalchemy.engine’ Install

pip install SQLAlchemy==1.3.22 should fix it

If sanic related error: pip install sanic-jwt==1.6.0

delete .db (events and rasa ) if is showing alembic issue.

Note: If you not able to install you can downgrade the pip version to 20.2

pip install pip==20.2

If you have any error in-between please share with me.

Note: You will see the Event Loop Close error in the terminal, you can ignore that, its an persistent issue with Rasa X and team is working on it.

I hope this will solve your issue. Good Luck!

okay let me try that

Thank you Chief. This method worked properly. Now I am working swiftly.

@CliveMakunga No worries, can I request to close this thread as a solution for others and for your reference?


@CliveMakunga ??