UserWarning: Action 'ut ter_mssv' is listed as a response action in the domain file, but there is no matching response defined. Please che ck your domain

I have it with the name in domain, I listed it in action: What did I miss?

Hi @juhonkang, we need some more information to debug the issue.

Maybe I will push it on github, thank you

Hello @juhonkang, i think you are trying to define utter response in action file. If you are trying that please share your and domain file.

domain.yml (1.1 KB) (2.0 KB) csdl.xls (166.5 KB)

Can you rename utter_msv with action_msv in all all places like domain.yml, stories.yml, and try to run it again. Utter responses has to defined in domain.yml not in as far I as know. It is always recommend to use action_intentName for writing custom actions rather than utter_intentName.

1 Like

It’s solved but partly

What is the exception :frowning:

Hello @juhonkang,

Have you started the action server in an another terminal using rasa run actions command.

If yes, please check endpoints.yml file where you need to uncomment the actiom server. (2.3 KB) csdl.xls (166.5 KB) endpoints.yml (1.4 KB) domain.yml (1.1 KB)

The endpoint is done but still have exception

Check the logs of the action server. Probably something wrong in your

In the console where you are running the actions server, it will print where the error occurred.

Can you post the screenshot of that console as well.

juhonkang/my_first_chatbot ( Please check it for total infomation

Why is your config file doesnt have any pipelines and policies. All are commented?

Your stories file is also incomplete. You have not written any stories for action or utterances

Probably he is using Rasa 2.0.

1 Like

That’s right

by the way, I have solved it myself. Thank you so much. (2 people I mean) :slight_smile:

That’s great. Can you mark the post as completed by marking one of our replies as solution. It will help others. Cheers