Unable to run bot in command line. Index error

Hello, I am using Rasa core v0.12.3 I have a simple trained bot in my model/dialogue folder and I am trying to run the bot by evaluating it. I have tried writing a script from rasa_core.agent import Agent from rasa_core.interpreter import NaturalLang - Pastebin.com

Also I tried running it from the following command: python -m rasa_core.evaluate default --core models/dialogue
–nlu models/default/healthbot
–stories data/e2e_stories.md --e2e

I even tried re-training the model using the commands give in the Rasa-core documentation, but the training goes smoothly.

I have tried many other commands but all of them are giving me the same Index error:

/usr/local/lib/python3.5/dist-packages/h5py/init.py:34: FutureWarning: Conversion of the second argument of issubdtype from float to np.floating is deprecated. In future, it will be treated as np.float64 == np.dtype(float).type. from ._conv import register_converters as _register_converters INFO:rasa_nlu.components:Added ‘nlp_spacy’ to component cache. Key ‘nlp_spacy-en’. /usr/local/lib/python3.5/dist-packages/rasa_nlu/extractors/entity_synonyms.py:89: UserWarning: Failed to load synonyms file from ‘models/default/healthbot/entity_synonyms.json’ “”.format(entity_synonyms_file)) /usr/local/lib/python3.5/dist-packages/pykwalify/core.py:99: UnsafeLoaderWarning: The default ‘Loader’ for ‘load(stream)’ without further arguments can be unsafe. Use ‘load(stream, Loader=ruamel.yaml.Loader)’ explicitly if that is OK. Alternatively include the following in your code:

import warnings warnings.simplefilter(‘ignore’, ruamel.yaml.error.UnsafeLoaderWarning)

In most other cases you should consider using ‘safe_load(stream)’ data = yaml.load(stream) /usr/local/lib/python3.5/dist-packages/sklearn/preprocessing/label.py:151: DeprecationWarning: The truth value of an empty array is ambiguous. Returning False, but in future this will result in an error. Use array.size > 0 to check that an array is not empty. if diff: Processed Story Blocks: 100%|█████| 1/1 [00:00<00:00, 2021.35it/s, # trackers=1] INFO:main:Evaluating 1 stories Progress: 0%| | 0/1 [00:00<?, ?it/s] Traceback (most recent call last): File “/usr/lib/python3.5/runpy.py”, line 184, in _run_module_as_main “main”, mod_spec) File “/usr/lib/python3.5/runpy.py”, line 85, in _run_code exec(code, run_globals) File “/usr/local/lib/python3.5/dist-packages/rasa_core/evaluate.py”, line 666, in cmdline_arguments.e2e) File “/usr/local/lib/python3.5/dist-packages/rasa_core/evaluate.py”, line 491, in run_story_evaluation use_e2e) File “/usr/local/lib/python3.5/dist-packages/rasa_core/evaluate.py”, line 433, in collect_story_predictions fail_on_prediction_errors, use_e2e) File “/usr/local/lib/python3.5/dist-packages/rasa_core/evaluate.py”, line 378, in _predict_tracker_actions fail_on_prediction_errors File “/usr/local/lib/python3.5/dist-packages/rasa_core/evaluate.py”, line 337, in _collect_action_executed_predictions action, policy, confidence = processor.predict_next_action(partial_tracker) File “/usr/local/lib/python3.5/dist-packages/rasa_core/processor.py”, line 168, in predict_next_action probabilities, policy = self._get_next_action_probabilities(tracker) File “/usr/local/lib/python3.5/dist-packages/rasa_core/processor.py”, line 478, in _get_next_action_probabilities tracker, self.domain) File “/usr/local/lib/python3.5/dist-packages/rasa_core/policies/ensemble.py”, line 291, in probabilities_using_best_policy if (result.index(max_confidence) == AttributeError: ‘NoneType’ object has no attribute ‘index’

Can anyone please solve my problem? I have been looking into it for days now.