Ubuntu 18.04 64 bits - (core dumped) error on launch

Unable to install rasa on my 4GB raspberry pi4 :frowning: , I tried to install it on another small laptop. On this one, rasa installs correctly but the launch of rasa displays an error (core dumped)

  • Python3 version: Python 3.6.9
  • Pip version: 20.0.2
  • OS Version (uname -a): 4.15.0-76-generic #86-Ubuntu SMP Fri Jan 17 17:24:28 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

When i launch rasa init (or other rasa command like rasa run), i got it:

Unable to init server: Could not connect: Connection refused
Unable to init server: Impossible de se connecter : Connection refused

(rasa:5988): Gdk-CRITICAL **: 15:07:43.599: gdk_cursor_new_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(rasa:5988): Gdk-CRITICAL **: 15:07:43.630: gdk_cursor_new_for_display: assertion 'GDK_IS_DISPLAY (display)' failed
Instruction non permise (core dumped)

Thank’s for help by advance :blush:

Is this the error you are seeing on the raspberry pi, or the small laptop?

Sorry, this error is only for the small laptop.

For the raspberry i had openned this topic: Can't install rasa on a Raspberry 4 4GB with Ubuntu 19.10 server 64 bits

Have you looked for solutions to this specific problem? I don’t think its a rasa issue but an issue with your server. Maybe this helps? Unable to init server: Could not connect: Connection refused gxmessage: unable to initialize GTK - #2 by pavlos_kairis - Support & Help Requests - Ubuntu MATE Community

Thank you for your answer. However, the first lines should not be taken into account as they only appear in SSH. When I take control of my server with VNC and I do a rasa init, I only get the error Instruction fault (core dumped) .

Interesting. Have you tried the solutions to the other core dumped issues recently (uninstall gym, install gym==0.15.4)? They’re segmentation faults, which makes me think it’s a different issue, but maybe it’s an instruction fault here because it’s on the raspberry pi.

The problem I’m talking about here concerns a DIFFERENT machine (a laptop). I have created another topic on this forum to make progress on the raspberry problem. On this laptop, installing version 0.15.4 of gym doesn’t solve the problem.