Training is failing when Fallback Policy is specified

Hello. I have an error when trying to execute rasa core training.

$ docker exec -it rasa_core bash -c “python -m rasa_core.train --domain projects/domain.yml --stories projects/stories. md --out models --c config/rasa_core_config.yml” Traceback (most recent call last): File “/usr/local/lib/python3.6/”, line 193, in _run_module_as_main “main”, mod_spec) File “/usr/local/lib/python3.6/”, line 85, in _run_code exec(code, run_globals) File “/app/rasa_core/”, line 351, in additional_args) File “/app/rasa_core/”, line 266, in do_default_training kwargs=additional_arguments) File “/app/rasa_core/”, line 172, in train_dialogue_model policies = config.load(policy_config) File “/app/rasa_core/”, line 22, in load return PolicyEnsemble.from_dict(config_data) File “/app/rasa_core/policies/”, line 197, in from_dict policy_name = policy.pop(‘name’) AttributeError: ‘str’ object has no attribute ‘pop’

I have tried default policy file from a documentation:


  • name: KerasPolicy epochs: 200 batch_size: 50 max_training_samples: 300
  • name: FallbackPolicy
  • name: MemoizationPolicy

But i have same error. How it’s possible to specify fallback policy properly?

Can be closed. It was invalid yml file.