Trained the bot but bot is not giving the action answer

Hi, i trained my rasa bot and when i run the bot using rasa shell it wont provide the relative answer from the bot action.

Your input ->  weather in London                                                                                                
Your input ->                     

My story is,

## weather_ask path
* greet
  - utter_greet
* ask_weather
  - action_some_resp_three

can someone please give an explanation for that.

action_some_resp_two is a custom action that i created in

London is an entity as well as a slot.

Sometimes my bot gives me wrong answers.

In here i asked for the weather an it gives me somthing like that.

You should probably provide more detail than this. Random ideas: action server running? Tried in interactive mode to see prediction scores and things?

yes @AllBecomesGood the server is running. No i did not try that. What should i do to get that interactive mode?

thanks a lot, but i tried even that, no luck :no_mouth:

I see you added a screenshot in the original post. That’s not interactive tho, so it doesn’t show you with which % it predicted the picture-cheerup-intent. When you use interactive and tell it that it predicted wrong it gives you a list of other predictions it made and with what %.

Given that it suggests that cheer-up intent, have you left that in the story data? (cause thats the base example). Also, how many examples do you have for your weather intent?

HI @AllBecomesGood i’m just learning rasa for a projects and this is a test that i’m trying to learn rasa. So my examples are like 23 for weather intent.

And i did train this with interactive mode. But the screen shot was from normal training method.

In my story i save a value to a slot. So it i ask the same question with a different value for my slot, will it keep the new slot value or do i have to change it in the code somewhere?

Hey, I’m not sure whether this is still relevant for you, but I had a similar issue, and with me it turned out to be related to the policy I was using. Basically what happened is that the stories I had written were usually pretty short, and that the memoizationpolicy has a history applied to it. The result of that is that it looks to match a story which doesn’t work. What helped for me was adding another memoizationpolicy with a custom priority and the max_history parameter set to 0.

If you can send some stories, that might be helpful!