The Callback URL or Verify Token couldn't be validated

I’m facing a weird problem. I have a proper setup for connecting to the Facebook channel.

  1. I’ve edited credential.yml as rasa docs.
  2. given verify token as my Facebook app name.
  3. expose port 5005 with ngrok. when I want to verify callback URL it continue to saying The Callback URL or Verify Token couldn’t be validated. when I click verify it doesn’t show any request in my ngrok dashboard as shown below:

but it works if I do it with a browser. sometimes chrome browser shows dangerous warning of this link https://bf199334c4ea.ngrok.io/webhooks/facebook/webhook

commend lines shows a warning

`2021-06-13 22:00:23 WARNING  rasa.core.channels.facebook  - Invalid fb verify token! Make sure this matches your webhook settings on the facebook app.`

What’s going on? any solve?

thanks in advance.

@AbuIshak Hope this will solve your problem https://www.youtube.com/watch?v=tFYS6JVYNTI&t=184s

If still problem persist do message.

I’ve followed all of those steps, but just stuck in.

Dose this problem come from any bug’s?

I’m using

Rasa Version : 2.6.3

Minimum Compatible Version: 2.6.0

Rasa SDK Version : 2.6.0

Rasa X Version : None

Python Version : 3.8.0

Operating System : Windows-10-10.0.19041-SP0

One thing, I was able to connect the Facebook channel with a brand new rasa project. then I edit the project and retrain it and it still works. once I try to reconnect it another time, now it’s showing The Callback URL or Verify Token couldn’t be validated again.

Can you share the error screenshot?

Actually there is nothing to share. In Facebook developer page, saying could not be validated. And in commend line no responses and ngrok dashboard no request get.

@AbuIshak To verify please type

Callback URL: https://cc5e480e9977.ngrok.io/webhooks/facebook/webhook

Verify Token: Your app name same as you mention in the credential.yml

Note: Check the commenting in the credential.yml, un-comment the code under Facebook.

For more help please see this Facebook Messenger OR What Callback URL should be for integration with FB messenger?

Hope this time it will work, I have checked and linked my bot for you, and it’s connecting.

Actually, the problem is with my ngrok version. The problem solved with ngrok windows (32-bit).

@AbuIshak Thanks its solved! I enjoyed helping your problem. I guess you got your solution.