[SOLVED] Tracker store not found

Hey everyone, i would like to create a custom tracker store but i am facing an error.

i followed this 3 following tutorials like 3 times, and some randoms tutorials on the internet:

but same error

Store type ‘f.Ff’ not found. Using InMemoryTrackerStore instead

this is my endpoint.py:

tracker_store:
  store_type: f.Ff
  url: localhost

(i have tried with “type” and “store_type”)

This is the f.py file:

from rasa.core.tracker_store import TrackerStore

class Ff(TrackerStore):

def __init__(self, url, domain):
    print("OUI")

the endpoint.yml and the f.py are on the same directory. the name of all class are short i know, this is for test purpose.

Can someone help me please? thanks

What directory are you starting Rasa in? Can you paste the command you are using to start rasa?

i run these 2 commands:

rasa run actions

rasa run --cors “**” --endpoints endpoints.yml --debug --enable-api

these 2 commands are on a makefile located at the root of the project

> ls
actions.py       endpoints.yml  models             policies.yml     tmp.mp3
config.yml       env            __pycache__         util            story_graph.dot
credentials.yml  f.py           rasa_core.log       out.log         Makefile
data             __init__.py    MyTrackerStore.py  rest_ia.sh       domain.yml

I’m in the process of migrating to 1.0 and my tracker no longer works. Same issue reported by @thom

WARNING  rasa.core.tracker_store  - Store type 'trackerArango.ArangoTrackerStore' not found. Using InMemoryTrackerStore instead

I’ve submitted GitHub issue #3867

Problem solved.

because our launch command is not python -m … you need to add the python path manually.

in my case:

  • export PYTHONPATH=<my path to my rasa folder> (just perform pwd)
  • make run_server (equal to ‘rasa run --cors “**” --endpoints endpoints.yml --debug --enable-api’)

Even after setting the PYTHONPATH, same error occurring again. Store type 'tracker.MongoTrackerStore' not found. Using InMemoryTrackerStore instead

I’m using Anaconda in Windows 10 and using rasa 1.0. I set the PYTHONPATH using set PYTHONPATH=<Path to rasa project folder>.