Running multiple assistant on same server with different port

I’m able to run 2 different assistants on the same rasa server on 2 different ports using the -p port. So I tried the same deployment for my 3rd assistant on same server with another port. The 3rd assistant is not responding, there are no errors from server and the rest webhook responds with “hello from rasa” . But the assistant is not responding with my UI. Do I have to make changes in the endpoints.yml related to the action server or is there any other configuration has to change.

The other assistants are working on 5002, 5003 respectively and I’m trying the 3rd assistant with the same command on port 5004

rasa run -m models --enable-api --cors “*” -p 5004 --debug

how you are communicating with rasa server ? have you change the port in UI, from where you are hitting the rasa server ?

With the rest channel. all the 3 assistants having unique rest webhook url

5002 assistant 1 http://localhost:5002/webhooks/rest/webhook

5003 assistant 2 http://localhost:5003/webhooks/rest/webhook

5004 assistant 3 http://localhost:5004/webhooks/rest/webhook (its responding with hello from rasa)

Try 5007,5008,5009. Maybe it can be that 5002 is colliding with rasa url at 5002.

Check your credentials file:

image

I tried for 5007,5008,5009. All of them are responding with “Hello from Rasa”

the assistant on 5002 and 5003 is using the same credentials and working fine.

rasa: url: “http://localhost:5002/api

after changing the port or rasa server from 5004 to 5008 I’m getting the same error

There are no errors in my logfile, this is the error i’m facing from frontendUI

Failed to load resource: the server responded with a status of 404 (Not Found)

and webhook replies “Hello from Rasa: 1.6.0”