Restarting Nginx Container in intranet

Hi, i have tried to deploy rasa x through docker compose and manage to get all the containers running except for nginx that keeps restarting. with this error “nginx 02:50:25.68 you have not agreed to the terms and conditions, Rasa X cannot start. To accept the terms and conditions run echo “${USER} $(date)” > /opt/bitnami/nginx/conf/bitnami/terms/agree.txt on the host machine. You can find the terms at https://storage.googleapis.com/rasa-x-releases/rasa_x_ce_license_agreement.pdf

Here is the context: I am trying to deploy rasa x in an intranet server. I first ran install.sh on an internet environment before moving the full rasa folder with docker-compose, terms certs, etc over to the intranet and then cd into the rasa folder before building the containers. For some reason, even though my terms are in the right place, nginx container was not able to read and mount even tho it is clearly specified in the docker-compose.yml file "nginx: restart: always image: “10.81.62.145:18079/rasa/nginx:${RASA_X_VERSION}” ports: - “80:8080” - “443:8443” volumes: - ./certs:/opt/bitnami/certs - ./terms:/opt/bitnami/nginx/conf/bitnami/terms depends_on: - rasa-x - rasa-production - app "

As i am not the main administrator of the server, i wasnt able to run sudo docker-compose up -d, but only docker-compose up -d to build the containers. Could all these possibly be a permission issue? Still haven figure out what ports are available in our intranet server, but that shouldnt cause the nginx container to restart right?

Were you able to get Rasa X running if you ran docker-compose up -d before you moved the full rasa folder?

Hi hsm, thanks for reaching out, sorry for the late reply, yes i was able to get rasa x running with docker-compose up -d. Here is what happened: I only have a macpro in the internet environment which is not an environment to set tup rasa x in, however, we use that to run install.sh before moving the files into the intranet. In the macpro environment, we did tried docker-compose up -d and all the containers were running, but its just that we couldnt setup rasa x production to create the user and password because rasa x should only be deployed in windows and linux according to the docs for docker compose. " I know we did it in a roundabout way haha…"

Just to add, the several solutions on the forum i tried involves changing to owner of agree.txt to the admin of the server( solution asked to change to root, but because of my company’s policy, the best i can do was to change it to an admin user with sudo privileges. The admin of the server also told me that even “normal users” like me should be able to run normal command as if i am sudoing because thats how they setup the server, not entirely sure about this, i am not well versed in how these servers work. To me it looks like a permission issue that in our company’s current infrastructure setup makes it difficult to work with rasa!

Hi @teoyangrui, since Rasa X version 0.39.0 the docker-compose.yml file should not refer to agree.txt anymore as it uses the standard Nginx docker image. On 0.39 or higher you can therefore also replace the nginx image with e.g. Nginx Unprivileged image if you have more permissions issues.

What version are you on? If you are on 0.39 or higher, make sure you also re-downloaded docker-compose.yml to get the updates.