Rasa X Upload/Train Issue

Hi guys, Here is a problem i’m facing currently , any help is appreciated . I couldn’t train a model based on Spacy:

So at this point i decided to upload a local model since the training passes in a local mode; Unfortunately that doesn’t pass too… is there any way that i can inject rasa models without training/uploading ? if not i’m stuck and i don’t know how to proceed . These are my files :

language: “fr”

pipeline:

  • name: SpacyNLP model: fr_core_news_sm
  • name: SpacyTokenizer
  • name: SpacyFeaturizer
  • name: RegexFeaturizer
  • name: LexicalSyntacticFeaturizer
  • name: CountVectorsFeaturizer
  • name: CountVectorsFeaturizer analyzer: “char_wb” min_ngram: 1 max_ngram: 4
  • name: DIETClassifier epochs: 100
  • name: EntitySynonymMapper
  • name: ResponseSelector epochs: 100

policies:

  • name: MemoizationPolicy
  • name: TEDPolicy max_history: 5 epochs: 100
  • name: MappingPolicy
  • name: FormPolicy

Running Spacy Validation gives this output : image

Thank you in advance .(BTW the training does work in my local project , so i think this issue has to do with Rasa X Deployment . Additional info : code error 500 ,preview in browser :

  1. {version: “0.27.6”, status: “failure”, message: “Failed to train a Rasa model.”,…}

  2. code: 500

  3. details: “500, Internal Server Error, body=‘b’{“version”:“1.9.6”,“status”:“failure”,“message”:“An unexpected error occurred during training. Error: Model ‘fr_core_news_sm’ is not a linked spaCy model. Please download and\/or link a spaCy model, e.g. by running:\npython -m spacy download en_core_web_md\npython -m spacy link en_core_web_md en”,“reason”:“TrainingError”,“details”:{},“help”:null,“code”:500}’’”

  4. help: null

  5. message: “Failed to train a Rasa model.”

  6. reason: “StackTrainingFailed”

  7. status: “failure”

  8. version: “0.27.6” )

Okay so stopping and restarting the docker containers resolved the issue , as soon as the containers were up and running again , the UI updated itself :

But still what was the issue ? is it just a Front end Issue or is it something else ?

Upload working too :

@pandaxar the reason the upload didn’t work is because you already had a model of that name uploaded.

Not sure why training didn’t work at first, it seems like you’re running Rasa X in local mode, which isn’t the officially supported way to run it.

1 Like

either way , i’m glad i didn’t get stuck here. I’ll mark your reply as solution for this issue , but further investigation by me is needed . Thanks for you efforts Akela .

I see in rasa -1.9 and rasa x 0.25 ui i cant train my model at all but rasa train on same folder structure works.The rasa UI based training isnot working The below is the error that I saw

2020-05-07 00:34:48 ERROR sanic.root - Exception occurred while handling uri: ‘http://xxxxxxxx:5005/api/projects/default/models/jobs’ Traceback (most recent call last): File “/var/rasa/rasa_workshop/venv/lib/python3.7/site-packages/sanic/app.py”, line 976, in handle_request response = await response File “/var/rasa/rasa_workshop/venv/lib/python3.7/site-packages/rasax/community/api/decorators.py”, line 205, in decorated_function return await await_and_return_response(args, kwargs, request) File “/var/rasa/rasa_workshop/venv/lib/python3.7/site-packages/rasax/community/api/decorators.py”, line 135, in await_and_return_response response = await response File “/var/rasa/rasa_workshop/venv/lib/python3.7/site-packages/rasax/community/api/blueprints/models.py”, line 191, in train_model content = await stack_service.start_training_process() File “/var/rasa/rasa_workshop/venv/lib/python3.7/site-packages/rasax/community/services/stack_service.py”, line 352, in start_training_process nlu_training_data = nlu_training_data.filter_training_examples( AttributeError: ‘TrainingData’ object has no attribute ‘filter_training_examples’

Hi @vaidehi, Rasa 1.9 and Rasa X 0.25 are not compatible. Please take a look at the compatibility matrix here

thank you

Hi @akelad

Suddenly I started getting the following error when trying to train my data:

Also I have tried to upload a model, but no success.

I can train it locally, using the latest github version, however not using Rasa X.

My logs folder (/etc/rasa/logs) is empty and I can’t identify what is happening.

I stopped and started the docker containers.

Would you know what is happening? And, if the case, how can I uninstall and install Rasa X?

Thanks in Advance

Hi guys, Here is my situation, Windows 10 ,manaual install docker compose, I get the same issue as you met, which got red error . After I check and compare my another linux environment which can train/upload model well ,I delete special character in .env ,then it’s worked