Rasa x stories export error

I probably need to submit an bug report, but I thought I’d see if anyone else had an idea.

Rasa version 2.20.1 Rasa x 0.36

Clickng the export button in Stories generates the following error:

2021-02-23 13:57:01 ERROR    sanic.root  - Exception occurred while handling uri: 'http://localhost:5002/api/stories'
Traceback (most recent call last):
  File "/home/randy/anaconda3/lib/python3.7/site-packages/sanic/app.py", line 939, in handle_request
    response = await response
  File "/home/randy/anaconda3/lib/python3.7/site-packages/rasax/community/api/decorators.py", line 216, in decorated_function
    return await await_and_return_response(args, kwargs, request)
  File "/home/randy/anaconda3/lib/python3.7/site-packages/rasax/community/api/decorators.py", line 146, in await_and_return_response
    response = await response
  File "/home/randy/anaconda3/lib/python3.7/site-packages/rasax/community/api/blueprints/core/stories.py", line 125, in get_stories
    project_id, stories, data.FileFormat.YAML
  File "/home/randy/anaconda3/lib/python3.7/site-packages/rasax/community/services/story_service.py", line 287, in get_stories_as_string
    return self._get_stories_as_yaml_string(project_id, stories)
  File "/home/randy/anaconda3/lib/python3.7/site-packages/rasax/community/services/story_service.py", line 252, in _get_stories_as_yaml_string
    is_test_story = any([story["is_test"] for story in stories])
  File "/home/randy/anaconda3/lib/python3.7/site-packages/rasax/community/services/story_service.py", line 252, in <listcomp>
    is_test_story = any([story["is_test"] for story in stories])
TypeError: list indices must be integers or slices, not str

Does anyone know a manual work around. I would like to have the changes made to my stories.

Hey @Randywreed, did you mean version 2.2.1? Can you try upgrading to 2.3.1 first? That’s the compatible version with 0.36

I was able to reproduce this, will create an issue for you.

Here you go: Export stories button doesn't work in Rasa X · Issue #8038 · RasaHQ/rasa · GitHub

Was this issue fixed? The GitHub tracker for this doesn’t seem to have a page anymore. I tried to export the stories in RasaX (38.1) Rasa prod (2.4.0-full) and get this error:

“Failed to load resource: the server responded with a status of 500 (Internal Server Error)”

However, I am able to make an API call to export the stories fine outside of RasaX. Do I have some incompatible versions or something? It worked in the past, then suddenly didn’t work.