RASA X - ImportError FormValidationAction deploying through Helm Charts


I am getting the following error in my app pod when deploying Rasa X through Helm Charts (using the tutorial):

ImportError: cannot import name 'FormValidationAction' from 'rasa_sdk.forms' (/app/rasa_sdk/forms.py)

Can somebody explain to me why this is happening, when I am using the latest versions of Rasa and Rasa X?

Thanks :slight_smile:

Your import should look like this:

from rasa_sdk import FormValidationAction

Hi @stephens,

Thank you for your response! However, when I run it locally it does work, so what is the difference when I deploy it using Helm charts?

You must be on different versions of Rasa. The above import is Rasa 2.0.

Hi @stephens,

I just checked my Rasa SDK version and it was 2.0.0 but I upgraded it to 2.1.1. Furthermore, my Rasa version is 2.0.2 and my Rasa X version is 0.33.0.

What I find really interesting is that when I run my actions server locally I can either do:

from rasa_sdk import FormValidationAction


from rasa_sdk.forms import FormValidationAction 

This works in both cases, can you explain to me why this does not work when I deploy it using Helm charts?

Thank you!

This does not work either, now I am receiving this error.

EDIT: This is using the Helm charts, not locally, locally everything is working fine.

I just checked the SDK version using the Helm chart deployment and it is 2.0.0rc1. This needs to be updated on Rasa’s side, I believe this is the problem.

@tmbo can you take a look at this?

It might be in the Github action as well (GitHub - RasaHQ/action-server-gha: A GitHub Action that simplifies using Rasa Actions and helps to prepare a Docker image with custom actions.), I am checking if I get the same problem when I specify the rasa-sdk version instead of using latest.

@tczekajlo might be the better person to take a look :sweat_smile:

@tmbo thank you for your response! When I set the version to 2.0.0 instead of latest it is working. However, the default is “latest” which refers to 2.0.0rc1. @tczekajlo can you take a look at this?

Now I get this error:

ModuleNotFoundError: No module named 'typing_extensions'

I managed to resolve the issue by adding it to my requirements.txt and referring to it.

1 Like

Had the same mistake, could fix it with your solution. Thanks for sharing it!