RASA X ERROR: Failed building wheel for ujson

@nik202 One of my friend is getting this error. He is doing the same steps as you told me yesterday. But he is getting this error after running this command pip install rasa-x==0.39.3 --extra-index-url Simple Index. I’ve attached a screenshot. Please help us.

@Smit Hi. Please install Microsoft C++ Build Tools and upgrade setuptools with

pip install --upgrade setuptools .

@nik202 Once again you have done it :star_struck:. Thank you so much for helping us. We really appreciate your advice and knowledge. :clap: :clap:

1 Like

@Smit Happy to help you :handshake::+1:

1 Like

i tried install the build tools 2019 and also upgraded the setuptools with command. but still get the error msg.

i solved the error via uninstall ujson in pip and conda. and then “conda install ujson==1.35” it works

1 Like

@MarcusPoon0303 great! :slight_smile:

Hi, Do you know how we can solve the same issue in linux environment?

@shethsankalp can you elaborate more? and do tag me please.