Rasa Widget: webhook blocked

hey, i build a virtual assistant and i’m using rasa widget to connect with a company’s platform, month earlier everything was fine until we start working on new features. i’m using a custom channel myio , no longer rest so i can exchange payloads .Now whenever i try to send message to the widget this shows up:

Access to fetch at 'http://localhost:5005/webhooks/myio/webhook' from origin 'http://localhost:8080' has been blocked by CORS policy: Response to preflight request doesn't pass access control check: It does not have HTTP ok status.


POST http://localhost:5005/webhooks/myio/webhook net::ERR_FAILED

eventhough i used --enable-api --cors “*” tag when i run rasa .

i tried every solution mentioned in other rasa forum posts about this issue and nothing changed

Hey @arsalen_gharbi,

Can you try using the --cors ‘*’ flag without the --enable-api flag and let me know what the result it? I’m seeing that another user had success with this approach: RASA Core: --cors parameter does not apply to socket.io - #12 by Serge

hey @mjaycub , i already used --core when the problem appeared , i found the source , it was from my custom channel, now it work fine