Rasa-webchat widget appears to connect to rasa server, but keeps saying "Waiting for server..."

Hi there,

I’m running the Rasa stack starter pack example (GitHub - RasaHQ/starter-pack-rasa-stack) with the Rasa webchat widget, embedded as script (based on the example at GitHub - mrbot-ai/rasa-webchat: A chat widget easy to connect to chatbot platforms such as Rasa Core), using the Rasa server socketio setup.

It appears to connect successfully (i.e. when running the rasa stack server, I see the log messages that suggest POST and GET request to e.g. /socket.io/?EIO=3&transport=polling&t=MThFYM_&sid=cfc8653cd08d4ba98127487495d5ad6a are successful and return a 200 code, but the web widget on the page continues to say “Waiting for server…” and the user input field stays disabled. There are also no XHR error messages from the web inspector, suggesting the connection to the Rasa stack server works (I can see these errors as soon as I stop the rasa server).

I’m kind of lost trying to figure out what makes the webchat widget think it is not connected to the server - any pointers or suggestions would be very welcome, thanks!


(btw - tried with both webchat-0.5.0.js and webchat-latest.js, with the same result)

Hi @mmenti, from your logs it seems that Rasa Core handles the requests properly. Have you considered opening an issue on the mrbot-ai/rasa-webchat github repository?

Thanks @ricwo - yes, I had some help there and just today managed to get it working, essentially by upgrading to the latest version of rasa core (from github) that seems to contain some new socketio functionality which, as far as I can tell, has fixed the issue. Thanks for your reply!

Same here, I had to update rasa_core to current git master.

Be careful the newest master version requires Python3.x

  1. Delete the package:

    pip uninstall rasa_core
  2. Pip install the Git-Repo:

    pip install git+git://github.com/RasaHQ/rasa_core.git

Same, but I tried with v 0.4.1 or so I think and it works?! So I guess it is a problem with the UI on that server.


For me this was the “optimal” solution from all suggestions across the forum. Once I changed the referenced built library it worked.