Rasa train: not send response to call_backurl

Version:

  • Rasa: 1.10.23
  • Python: 3.7.5

I followed the “Train a rasa model” documentation here and added the call_backurl parameter to the parameters. But after the training is complete I still don’t see the results sent to call_backurl.

Hope to see a resolution ^^

Hi @baphuc1998 have you checked that the response status code to the POST training request is 204? Are you able to share:

  • how you’ve added the query parameter - double-checking that there’s no typo since the query parameter should be callback_url

  • how you’re checking that the callback URL you’ve provided received the results?

Hi @anca! sorry for the late reply. I use Flask to create a callback_url and I have put it in requestbody as follows:

{
    "domain" : "...",
    ...
    "force": true,
    "save_to_default_model_directory": true,
    "callback_url" : "https://4ba3fbd13cbf.ngrok.io/api/webhooks"
}

After the model training is finished and the model is saved to the app/models directory. I checked to see if there was a request sent to callback_url but nothing.

Hi @baphuc1998 callback_url is a query parameter, so it doesn’t belong to the request body, instead use it in your request URL, for example: http://localhost:5005/model/train?callback_url=https://4ba3fbd13cbf.ngrok.io/api/webhooks. Let me know if this doesn’t work.

@anca Even though I tried putting the callback_url in the params it still doesn’t work. No request was sent to callback_url after I finished training

Is there a problem with the version of rasa I’m using?

Hi @baphuc1998 Yes, it might be the case that the version you’re using doesn’t support query parameters, for example I checked the legacy docs for 1.x here and I couldn’t find any information on callback_url. According to the changelog, the callback_url parameter was introduced in version 2.2.0, please see entry listed here: #7408. We always recommend using the most up-to-date version that will contain both bugfixes and enhancements.

1 Like

Thanks for your answer. I want to use the supervised_embeddings pipeline so I can’t upgrade. In version 2.x I seem to spend a lot of time on training without supervised_embeddings.