Rasa train gives a cryptic TypeError

When running rasa train I am getting TypeError: argument of type 'NoneType' is not iterable. Based on the error message it seems like module_path is of type NoneType, but I’m not sure what to make of that. I’ve tried recreating my virtual environment (Rasa v2.1.3, Python v3.8.0) to no avail. I’ve attached the error message along with my domain.yml and nlu.yml file. You can see that all intents listed in my domain are also trained with NLU data.

domain.yml (15 KB) nlu.yml (2.1 KB)

Hey @alexyuwen, I tried this locally with your files and I found the issue to be in the domain where type is twice mistyped as tyoe:

  goal_recommendation: # for Sesssion 1 only, set by custom action --- Step 4.0
    tyoe: text


    tyoe: bool

With the typos corrected, everything works :slight_smile: However, I agree that the error message is totally cryptic. Would you be up for creating a proper GitHub issue for this (i.e. improved error handling for this specific case)? :sunglasses:

1 Like

Thank you @SamS, that fixed it! I also went ahead and posted this issue as a feature request here: Improved error handling for misspellings in domain file · Issue #7516 · RasaHQ/rasa · GitHub.