Rasa server problem CURL -XPOST /parse


I have set an azure VM which i have configure 3 containers : rasa_core + rasa_nlu + rasa_actions, build with the main source and the docker-compose from the github.

Every servers are up and work fine, but when i try to CURL -XPOST the rasa_nlu server with juste a “hello” as query, it give a strange error :

curl -XPOST my_server_ip:5000/parse -d ‘{“q”: “hello”}’

{ “error”: “‘str’ object does not support item assignment” }

Anyone have an idea of this problem ? Rasa nlu version problem ?

rasa_nlu : “version”: “0.14.0a1”



it’s probably something to do with how the quotation marks are placed. what’s the OS of the system?

It is an ubuntu server

$ uname -a Linux 6af77a413901 4.15.0-1025-azure #26-Ubuntu SMP Tue Sep 25 09:20:29 UTC 2018 x86_64 GNU/Linux

Had an issue with post as well, tried changing quotes around:

curl -X POST http://localhost:5005/model/parse -d “{‘text’: ‘hello’}”

I get this error: {“version”:“1.4.3”,“status”:“failure”,“message”:“An unexpected error occurred. Error: Failed when parsing body as json”,“reason”:“ParsingError”,“details”:{},“help”:null,“code”:500}

Edit: I solved it with backslashes: curl -X POST -i http://localhost:5005/conversations/user/messages --data “{ “text”: “ve ry good”, “sender”: “user” }”