Rasa installation issue

Could not install packages due to an EnvironmentError: [WinError 5] Access is denied: ‘c:\programdata\anaconda3\lib\site-packages\requests-2.21.0.dist-info\INSTALLER’ Consider using the --user option or check the permissions.

I got this error…I need help with it

image

Well did you try installing using the --user option?

@erohmensing i did not…because I didn’t understand what ‘–user’ is…

If this is what you meant, I just tried this

pip install rasa-x --user --extra-index-url http://pypi.rasa.com/simple

I tried what you’ve said i.e, ‘pip install rasa-x --user --extra-index-url http://pypi.rasa.com/simple
and I got this…

then i tried this pip install rasa-x -i https://pypi.rasa.com/simple and got the following

Sorry one last thing to try, i accidentally missed out the s in that, can you try

pip install rasa-x --user --extra-index-url https://pypi.rasa.com/simple

If that doesn’t work you will have to run the commands with administrator privileges (you can google how to do this in windows), and the command would be the normal

pip install rasa-x --extra-index-url https://pypi.rasa.com/simple

can i ignore these warnings??

using this command i got the following, which is clear that I’m able to install rasa…then why can i not create a new project ?

pip install rasa-x --extra-index-url https://pypi.rasa.com/simple

You shoudn’t ignore the warnings, as they’re telling you that wherever you installed rasa isn’t on your PATH. That’s why it can’t recognize the command. Looks like you successfully installed it. In that message does it tell you what folder it was installed to?

it doesn’t tell what folder it is installed to…

From your earlier message log, using

pip install rasa-x --user --extra-index-url https://pypi.rasa.com/simple

command, the rasa and it’s dependencies was installed to

C:\Users\yashu\AppData\Roaming\Python\Python37\

Next time remember it’s better to use a python virtual environment.