Rasa Eats Memory. Is Garbage been handled?

I have 10 chatbot running in different ports with 10 different action server.(even tried with 1 action server not a big change in memory) Each chatbot have 2000 or more intents. I am using fallback and the response will be ‘$no out$’ I will hit all the 10 application api and from where I get response which does not starts with ‘$’ is my response. When all the 10 chatbot runs in background it uses more than 25 gb in which 15gb takes from free memory and other from available memory.

rasa version 1.2.3 OS : ubunbtu

Is there any way I could reduce the memory?

My config file

Is there any way to load spacy only once and use it in all my 10 applications?

see this issue Removing projects · Issue #3259 · RasaHQ/rasa · GitHub

Thanks for your quick response Alan. According to my understanding I cannot load multiple projects to same appliacation as I am using rasa 1.x.So I continued to run 10 different API for 10 applications using run --enable-api command and by specifying 10 different port number.

Since it runs 10 times it loads spacy 10 times in the memory so it eats more memory.Is it possible to load spacy only once and make all other api to use the same spacy but different models(core and nlu) since my config.yml is same for all?

I even tried to concat all applications together and train as one project. I m endingup with memoryerror after training for 2 hours.

Any suggestions to overcome memory issue.

since you are using English, I would recommend using the convert featurizer instead. It uses much less memory and also gives better performance!

I am not sure if I miss anything. I have installed tensorboard==1.13.1




tensorflow-text==1.15.1 I am getting the following error. Failed to find component class for 'ConveRTFeaturizer’Unknown component name. Check your configured pipeline and make sure the mentioned component is not misspelled.

Thanks in advance

are you using 1.5.0 or later? rasa/CHANGELOG.rst at master · RasaHQ/rasa · GitHub

Rasa: 1.2.3 .

can I use the convert in rasa 1.2.3?

you need 1.5.0 or above

I have found solution to load from local thanks.But after using Convert I am getting response correct but my confidence level is too low Initially with spacy I got 0.85 - 0.98. for matching values Not i am getting only 0.25 - 0.4

Please advice