Rasa data validate fail - could not read the file using utf-8 to decode it

Hi guys, I want to create an easy bot in order to understand how rasa works (Rasa version 2.8.1 , Rasa sdk version 2.8.0 ).

I removed all utters and intents of the native project after “rasa init”. I create my intents , utters but when I type “rasa data validate” or “rasa train”, this message appears in the terminal:

FileIOException: Failed to read file 'C:\Users\luigi\Desktop\esempi_rasa\prova\data\nlu.yml', could not read the file using utf-8 to decode it. Please make sure the file is stored with this encoding.

How can I solve it?

The question has been already posted and solved here: Can't run rasa x - Could not read file using the utf-8 coding

Check if the solutions there apply for you.

I’ve seen the topic, but my nlu file is yet .yml so I can’t verify the solution "change the extension from .md to .yml "

Okay, open the file using VS Code, do you see “UTF-8” in the lower-right corner?


Yes, I see UTF-8 in the right corner

Try executing set PYTHONUTF=1 in the command prompt and run the command again


Does the same error appear on a fresh project (rasa init)?

I just trained a new rasa project without any problem.

Okay, please try copying the contents of your files (not the files themselves) from the old project to the new one and try again

Thank you so much, now I validate data and another error appears : the error was that I wrote in stories: “slow_was_set” instead of “sloT_was_set” … thank you so much chris

1 Like

Happy to help! :slight_smile: Glad you got it working

1 Like