Problem loading actions on 0.11.2

I have just updated to 0.11.2 from 0.10.4 and their is a whole lott of things changed and i am struck on using my actions. I am getting below error on running my core server with command

python -m rasa_core.run --auth_token rasabot -d models/current/dialogue -u models\nlu\default\current -o out.log --endpoints endpoints.yml

Failed to run custom action ‘action_welcome’. Action server responded with a non 200 status code of 500. Make sure your action server properly runs actions and returns a 200 once the action is executed. Error: 500 Server Error: INTERNAL SERVER ERROR for url: http://localhost:5055/webhook

Did you start your action server? Please refer to the migration guide

yes i did

How? Please post some more details, including the command you ran to start it and the contents of your endpoints.yml. Also the logs that come from the action server

by running this command

python -m rasa_core_sdk.endpoint --actions actions

endpoints.yml -

action_endpoint: url: “http://localhost:5055/webhook

getting this on passing a query

actions server

Ok that looks fine. Apart from that your templates don’t seem to be specified. Are they specified in your domain file?

yes i have added the actions in my domain do you want me to send those too?

Yes and please also post the contents of the endpoints.yml

endpoints.yml -

action_endpoint: url: “http://localhost:5055/webhook"

domain -

https://gist.github.com/NikhilBansal21/a65eb4c617338e47eff79150132bb2c3

You dont have a template for ‘utter_welcome’ in your domain file. It’s not specified under “templates”, but you do have it referenced under actions. Do you have it coded in your actions file?

1 Like

yes it is in my actions.py

on mentioning ‘utter_welcome’ into templates also i am still getting error

resolved this using missing endpoint --enable_api in the run command

1 Like

Hi Nikhil,

Can you please share full command for enable api. I m currently running : python -m rasa_core_sdk.endpoint --actions actions

How to modify this command to enable api or there is another command?

When I m training my bot using custom action in another prompt I am getting error as : Action responded with non 200 status code of 500

hi,

You will have to add this

action_endpoint: url: “http://192.168.0.117:5055/webhook

in a endpoints.yml file

and then you for a separate action server go for this command

python -m rasa_core_sdk.endpoint --actions actions_reset

here actions_reset is the name of the python file containing custom actions code

and for core run this command

python -m rasa_core.run --auth_token rasabot -d models\dialogue -u models\nlu\default\current -o out.log --endpoints endpoints.yml --enable_api

Hope this helps :slight_smile:

Hi Nikhil,

Thanks for the help.

But when I am running core command before that I have to train my bot. So directly if I am running then how to handle custom actions ?

if i understand what you are trying to ask here stories will play their roles which you will train the bot with . Action server returns the required action which will be trained by you

Yes… when i have trained my stories I need to call custom_actions… SO at that time when I m calling custom actions I was getting above error…So basically my bot is not able to get trained with custom actions

Can you explain more on this please? how did you solve it?

Thank you.