Problem in file of rasa package

I was upgrading rasa to the latest version which is 3.0.4 and it got me this error (ImportError: cannot import name ‘EntityExtractor’ from ‘rasa.nlu.extractors.extractor’ (C:\Users\User\Anaconda3\envs\updated_rasa\lib\site-packages\rasa\nlu\extractors\

So, if anyone can help me , I will be so thankful.

Thanks for your time in advance !

@Mostafa_Saeed what method you are using for upgrading?

pip3 install --upgrade rasa

@Mostafa_Saeed can you try install with pip install rasa==3.0.4

I think its something related to rasa x , as when I re-install rasa x it downgrade rasa automatically to 2.8.21 (Note: I got this error when I run ‘rasa run actions’)

So, is there a rasa x version compatible with rasa 3.0.4?

@Mostafa_Saeed you posted this issue in the category of rasa open-source and rasa x is still not compatible with rasa 3. x any version.

@Mostafa_Saeed please be specific about what you trying to install its rasa x or rasa open source version 3.x

Yes got it!

Thanks for your help!