No registered action found

Hi,

I installed Rasa X on my server with Docker, it works fine except for custom actions.

When I run docker-compose up, all my actions get correctly registered:

However, when I talk with my bot triggering one of them, I get the following error:

app_1              | DEBUG:rasa_sdk.executor:Received request to run 'start_treatment_form'
app_1              | ERROR:rasa_sdk.endpoint:No registered action found for name 'start_treatment_form'.
app_1              | DEBUG:sanic.root:CORS: Request to '/webhook' matches CORS resource '/*'. Using options: {'origins': ['.*'], 'methods': 'DELETE, GET, HEAD, OPTIONS, PATCH, POST, PUT', 'allow_headers': ['.*'], 'expose_headers': None, 'supports_credentials': False, 'max_age': None, 'send_wildcard': False, 'automatic_options': True, 'vary_header': True, 'resources': {'/*': {'origins': '*'}}, 'intercept_exceptions': True, 'always_send': True}
app_1              | INFO:sanic.access:
rasa-production_1  | 2020-03-18 10:51:15 ERROR    rasa.core.processor  - Encountered an exception while running action 'start_treatment_form'. Bot will continue, but the actions events are lost. Please check the logs of your action server for more information.

Does anybody know how to help me?

Try with rasa run -m models --enable-api --cors “*”

Hi @vaidehi, thank you for replying, but it’s a server deployment, it’s not installed locally. I run my actions with docker-compose up

@tiziano is there any further logs in the action server once the error happens?

What is the specific command for the action server logs?

Btw I don’t think so. When I run docker-compose up I should see all the logs right? And this is what I see:

can you instead run docker-compose up -d and then get the logs with docker-compose logs app once you’ve sent a message to the bot that should trigger the action

Hi, is this issue solved? I’m also facing the very same issue, thanks

Hi, Is there a solution for this? I am facing a Similar Issue.

I had the same issue where form action wasn’t found I followed (Ep #9 - Rasa Masterclass) Improving the assistant: Setting up the Rasa X | Rasa 1.8.0 - YouTube.

Didn’t follow any other steps of creating action server separately


Finally - all started working

Get Action server Image container Id by running

Run : sudo docker ps

The container Id 603339fd04e0 is mapped to Image: rasa/rasa-sdk:latest
COMMAND : "./entrypoint.sh Ports : 5055/tcp

Run: sudo docker container restart 603339fd04e0

This is the action server, I restarted then Rasa X was able to find the actions registered, and is responding.