NLU bot displaying null when entering alphanumeric word i.e SR85296341


My nlu pipeline is -

language: “en”


  • name: “tokenizer_whitespace”
  • name: “intent_entity_featurizer_regex”
  • name: “ner_crf”
  • name: “ner_synonyms”
  • name: “intent_featurizer_count_vectors”
  • name: “intent_classifier_tensorflow_embedding” intent_tokenization_flag: true intent_split_symbol: “+”

I have some ticket number in this format - i.e SR12345698 , this works fine when entered this word within a sentence like - “ticket status for SR12345698” , but on entering it alone bot returns

{ “query”: “SR12345698”, “topScoringIntent”: { “intent”: null, “score”: 0 }, “intents”: [ { “intent”: null, “score”: 0 } ], “entities”: [ { “entity”: “SR12345698”, “type”: “IncidentID”, “startIndex”: 0, “endIndex”: 9, “score”: 0.9694517848359389 } ] }

Is this under the same intent or do you have a something like an /inform intent?

no i have not added it to a single intent /inform i have a different intent for this phrase

Oh okay. I’ve never tried the tensorflow pipeline. Not sure if that is causing the issue.

@Juste ?

Hey @NikhilBansal21. I think you are facing a very similar issue as here: Rasa_nlu returns intent as null for training samples using tensorflow classifier(Chinese) · Issue #1515 · RasaHQ/rasa_nlu · GitHub

My first suggestion would be to add a few exaples of providing just the ticket number so that the model would learn that these kind of inputs can appear too, not just the ones surrounded with actual words

i have done that… i have provided with utterences but its of no use as you can see it is catching intent as null but picking up the entity

Hmmm, that’s a bit odd. What’s the ration of examples with just ID vs the examples with ID+surrounding words in your training dataset?

yes i have provided enough amount of training data including just ID and ID + surrounding

and i tried installing mitie getting this error -

The image shows a number of only id’s mentioned in my training data