NLU 0.14.4 with tensorflow 1.12.0 unable to extract entities

Hi, everyone. I recently learned a bit about the Rasa stack and finally decided to give a try. I installed the Core(0.13.2) and NLU(0.14.4) in anaconda with python 3.6.8 by following the official document found on (Installation) with tensorflow; then cloned the Starter-pack and it is running fine after training the NLU and Core.

But then I tried to use tensorflow in the NLU with following nlu-config:

language: “en”

pipeline:

  • name: “tokenizer_whitespace”
  • name: “ner_crf”
  • name: “ner_synonyms”
  • name: “intent_featurizer_count_vectors”
  • name: “intent_classifier_tensorflow_embedding”

It detects the intent, but unable to extract the entity (“name” in this case with “i am sally.”)

Then I tried with spacy, and it works fine:

language: “en”

pipeline:

  • name: “nlp_spacy”
  • name: “tokenizer_spacy”
  • name: “intent_entity_featurizer_regex”
  • name: “intent_featurizer_spacy”
  • name: “ner_crf”
  • name: “ner_synonyms”
  • name: “intent_classifier_sklearn”

Any suggestions? Thanks in advance.

sdk

Well, it does able to get the entity(name) after I put

i am sally

into the “nlu_data.md”…

another questions, how can I always capitalize name when NLU detects it?

Thanks.

I wrote a custom NLU pipeline component to solve this issue. You can get it here. It converts a named entity to Titlecase.

If you use the Spacy ner extractor, which extracts names as an entity called PERSON, then add PERSON to the list of entities in the configuration file.

Hope that helps!