New Rasa server with Webchat not working

I have worked before with the early rasa_nlu and I have one Linux computer (Ubuntu 18.04) with working Rasa 1.3.1 installation. Now I wanted to install new Rasa to my new server, create a new bot and connect it to Webchat. This works fine in that old computer.

After a long and hard battle I managed to install the latest Rasa version to Ubuntu 18.04 (Python 3.6) server. First I tried to install it to venv but it kept failing. Maybe I got it wrong somehow. But it is now installed in the server. ‘Rasa init’ worked fine.

When I run ‘rasa run –enable-api’ –cors “*” –debug’, Rasa server is starting but the debugging seems to stop at a point: ‘rasa.core.nlg.generator – Instantiated NLG to ‘TemplatedNaturalLangugeGenerator’’.

In my web server Webchat tries to GET http://localhost:5005/… but there is ERR_CONNECTION_REFUSED.

If I curl localhost:5005, I get “Hello from RASA”.

Credentials.yml (socketio) should be configured fine, as I have this working in the other computer.

Any suggestions what to try next?

Hi did you find a solution ?

Yes I did, sorry I forgot to get back to this. The server I was using is a cloud instance and I had to open the port 5005 in the security group. So there was nothing wrong with Rasa installation!

Thank you !