Model Training Enpoint return .tar file instead of file name

Hi, I have read the doc # Rasa - Server Endpoints (1.0.0),
I’m tring to use the Model / Train a Rasa model endpoints,
But I found that the response of model training is a zipped file (.tar.gz),
instead of model filename (as document said).

In short, Model is successfully trained, but response is not a file name.

I tried to use callback server to retrieve request, the request header content-type is’application/x-tar’ instead of “application/octet-stream”.

The attachment is postman collection.

Ref: Rasa & Rasa Pro Documentation

  • OS: Win10
  • Rasa: 2.8 Python: 3.7

Chatbot.postman_collection.json (7.1 KB)

Helo @RUI-LONG are you able to train the rasa model using API, can you share the code, please? and can you confirm the rasa open source version? It 2. x right? rasa --version?

@nik202 Thaks for your reply !

Here is what I have done: First I clone the repo below

Then I run “rasa run actions” & “rasa run --enable-api --cors “*” --debug” in two different terminals.
And I use the model training endpoint (Postman Link is provided above),
got the .tar file response.

Thanks for your reply again!