Local rasa x installation fails

I am trying to install Rasa X for local mode.

        >   | Rasa Version     : 2.2.10
          | Rasa SDK Version : 2.3.1
          | Rasa X Version   : None
          | Python Version   : 3.6.9
          | Operating System : Linux-4.19.121-linuxkit-x86_64-with-Ubuntu-18.04-bionic

pip install rasa-x==0.35.0 --extra-index-url https://pypi.rasa.com/simple

It was taking way too longer. Then I had to downgrade pip to 20 then it moved ahead. But now I am getting following error

alembic.util.exc.CommandError: Can’t locate revision identified by ‘e2b7e06f6dc5’ rasa-dev-x | rasa-dev-x | Sorry, something went wrong (see error above). Make sure to start Rasa X with valid data and valid domain and config files. Please, also check any warnings that popped up.

Okay I am able to solve this with lots of trial and errors:

Please follow below steps:

  1. Downgrade pip pip install --upgrade pip==20.2 pip -V

  2. check compatibility between rasa-open source+rasa sdk+rasa x from here: Compatibility Matrix

Now based on your rasa open source+sdk version choose correct rasa x .

  1. Install rasa x

In my case it is 0.35.0

pip install rasa-x==0.35.0 --extra-index-url https://pypi.rasa.com/simple

  1. Remove local DB (stored on your root of project directory) rm -rf rasa.db rm -rf events.db

  2. Run rasa rasa x -v --vv (give correct path for config/domain/data folder if you have changed their default location)

  3. Now this will if you have mistake in your configurations. correct those.

    e.g.

    • synonym: altroz examples: |
      • altroz
      • agaltroz
      • altoz
      • tata altroz
      • tata agaltroz
      • tata altoz

Here entity value and synonym value is same: ‘altroz’

In this case Rasa tried to raise warning but that warning message itself was failing. :smiley:

So there was no clear indication what was failing. After traial and errir i have removed altroz entry and everything worked fine.

Similarly if you have defined roles for entities in domain file. Rasa gives error. So I had to remove those.

1 Like

Thank you so much for the solution