Issue in training intents


I have installed rasa version {“version”:“3.3.0”,“minimum_compatible_version”:“3.0.0”}. I am training the intents and examples using the HTTP API “/model/train” from our UI. Before training the question we will first call “/model/parse” API for checking if the current input is already trained or not. The very first intent was trained successfully. But when I tried “/model/parse” it didn’t return the expected intent. After that I trained a second input and that was also successful. Then on trying “/model/parse” with the first input it worked. But the issue is that after the second input all other inputs are returning either of the previous intents in “/model/parse”. SO we are not able to train other inputs.

How we can fix this issue? Is there anything that we miss on calling the API?


You should be running rasa data validate everytime before you train. You should also following the testing recommendations here. You could be having intent classification issues.

Hi @stephens , Thanks for the reply. But we are using only NLU. So I think ‘rasa data validate’ don’t work.

What we do is, before training an input, we first check if the question is already trained in any other intent by using ‘model/parse’ API. If the confidence level is lower than .8 we will train the new input in the corresponding intent.

Do we need to make any changes in the config.yml pipeline as the ‘model/parse’ is always returning wrong intent.

You should be using the NLU tests I referenced above.