Interactive Learning better than real Bot

rasa-core

(Max ) #1

Hey there!

I’m using the interactive learning script provided by the examples (train_online.py). When I’m using it to create training stories the prediction of the next action is nearly perfect. But as soon as I run the bot normally it behaves poorly even when I’m going along the path of a training story step by step!

(EDIT: It doesn’t seem to be a problem with training epochs. Even the flag --epochs 200 hasn’t solved the issue)


(Max ) #2

Okay I think I was able to get near the solution: As soon as I’m setting the flag --batch_size 50 for the learning command the result is a lot better!


(Akela Drissner) #3

Have you retrained the bot after including the stories generated by interactive learning?


(Max ) #4

Yes I did a training after each interactive learning


(Akela Drissner) #5

I’d guess there’s a problem with some conflicts in your stories. Go through your stories and check that isn’t the case. You can also run Core in --debug mode and that should give you some insight as to what’s going wrong, there’s some more info on this here: http://rasa.com/docs/core/debugging/