Integrating Rasa with Google Home

(Mukunda Varma) #1

Hey team , First of all , i would like to appreciate you for the great work done . Your docs are excellently written . I was trying to build a basic level chatbot with just one custom action in it . Since I was doing it with the help of Docker , i followed the steps from Building Rasa with Docker. And for integrating with google home , i followed Going beyond ‘Hey Google’: building a Rasa-powered Google Assistant . While trying to execute the run_app.py , I initially got the following error

. I am assuming that, while using docker , the file metadata.json is the same as policy_metadata.json(this is being created without using docker). I tried renaming metadata.json to policy_metadata.json and my core stopped working . So , instead of renaming , I created the file policy_metadata.json by myself with the same code as metadata.json. Now, on running the run_app.py , I am getting the following error . I tried several ways to resolve the issue . But none of them worked. would appreciate if you could help.

(Ella Rohm-Ensing) #2

Thanks for the compliments, @Mukunda13! Glad you’re getting a good start to Rasa. Can you tell me what versions of core, nlu, and sdk you’re running? It’s possible the version change since the tutorial was released is causing you some problems.