Installation of Rasa open source in Jupyter notebook

I am trying to install Rasa open source as per the instructions at

import nest_asyncio

print("Event loop ready.")

from rasa.cli.scaffold import create_initial_project
import os

project = "new-test-project"

# move into project directory and show files

Unfortunately, I am getting the following error. Appreciate any suggestions how to overcome this.

ModuleNotFoundError                       Traceback (most recent call last)
~\AppData\Local\Temp/ipykernel_18328/ in <module>
----> 1 from rasa.cli.scaffold import create_initial_project
      2 import os
      4 project = "new-test-project"
      5 create_initial_project(project)

ModuleNotFoundError: No module named 'rasa'

@valmetisrinivas did you install rasa in conda ? !pip install rasa or !pip install rasa==<version> Or check the rasa version?

Thanks for reverting with your suggestions. The documentation at Jupyter Notebooks ( does not hint about rasa installation. However I did try to install rasa with !pip install rasa command, !pip3 install rasa and !pip3 install rasa==3. from inside jupyter notebook. Still the same result. I guess the problem is rasa installation itself. Finally, I tried installing at Anaconda admin CLI using pip3 install rasa==3. Though it uninstalled and installed many other packages/ dependencies, it worked. Rasa got installed and now my Jupyter Notebook works.:slight_smile:

@valmetisrinivas great, please close this thread as a solution.

Sure. Not sure how to close. However, selected it as solution hoping that closes the thread.