'Incorrect data check' on installation

Hi everyone,

I’m trying to install Rasa on a centOS7 VM, via the commandpip install rasa but I keep encountering this error : ERROR: Could not install packages due to an EnvironmentError: ('Received response with content-encoding: gzip, but failed to decode it.', error('Error -3 while decompressing data: incorrect data check',))

PS: my pip is up to date, as well as python.

Thanks guys for your help !

I tried another method, by cloning the git repository, but got this error :


Could it be linked ? Am I the only one impacted ?

Hi @aeu1, this isn’t something I’ve seen before, but let’s see if we can figure it out - which python is your venv on (3.6? 3.7?). Can you clone other git repositories to the same location without issues? Can you pip install any other packages?

Python 3.6, and it worked with some packages, and some other not.

Cloning the git repository works today … As well as installing with pip …

I’m working from home, so I guess that my company’s network settings was blocking some of the trafic. That’s strange, but for now it seems to be working.

Glad it works now! Proxy settings at work that block github or Pypi would definitely cause problems.