How to get access to the default Rasa X Postgres database?


I am trying to get access to the default Rasa X Enterprise Postgres database and I can’t manage to find the correct credentials.

I know that with Rasa X Enterprise we automatically get Postgres database set up. Using kubectl -n rasa-x get services command, I managed to find an IP address for the rasa-x-postgresql service (and I am not sure if that’s the correct way), and for the password I tried to run kubectl get secret rasa-x-postgresql --namespace rasa-x -o yaml command.

However, with the credentials that I got this way I can’t open the database connection using pdAgmin4.

Does anyone know where do I find the exact credentials that I can use to get access to my Postgres database?

I would really appreciate your help!

The credentials you see in the secret are base64 encoded. What you can do is:

echo "base64-encoded-credential" | base64 -d

and you will get the original value.

In one command:

kubectl -n rasa-x get secret rasa-x-postgresql -o jsonpath="{.data.postgresql-password}" | base64 --decode

Hope this helps!

Using Oracle as your Rasa Enterprise database instead of PostgreSQL requires some additional setup, which we’ll go over here. Database Setup… More information is here:


Hi Dimitri,

Thank you for your response! I tried this and it still doesn’t work. Do you know where on google cloud can I find the rest of the server credentials for the built in Postgres database? So far I’ve been trying the following:

  • Host: the internal IP from kubectl -n rasa-x get services
  • Port: 5432
  • Maintenance database: postgres
  • Username: postgres
  • Password: the password from kubectl -n rasa-x get secret rasa-x-postgresql -o jsonpath="{.data.postgresql-password}" | base64 --decode

Do you know if the fact that I only have the internal IP address might be the problem?

Also I’m not sure what’s the correct maintenance database and username and where to find it. Do you maybe have an idea?

Hi Lena,

  1. What do you mean exactly when you say “it doesn’t work”? Can you share a log of how you configure credentials and what happens?
  2. Where does the process run which needs to connect to Postgres? In the same Kubernetes cluster or not?